Toad World® Forums

TOAD 6.5 for DB2 not recognising procedure statements

Hello,

I have just upgraded to 6.5 and I am getting a problem which I didn’t get in 6.1.

When I put statements such as :

DECLARE v_current INT DEFAULT 0;

in to the editor I get the “red star” syntax error highlight, see below

However, if I remove the semi colon from the first line, the second line no longer errors:

I’m sure this is a configuration issue, but I can’t see which option to change to fix this problem.

Look forward to hearing from you.

Many thanks,

Bob.

I have discovered that if I include the the “Create Provedure as” statement I get fewer errors:

But it still doesn’t explain why 6.1 worked without the “Create Procedure” statement and 6.5 doesn’t

Toad does not support anonymous blocks of PL\SQL.

In 6.1 there were Toad syntax parser issues that did not flag those individual statements.

In v6.5 the syntax checker was updated and now (correctly) flags those statements if they are not within the syntax of a Create Procedure statement (or the like).