Toad World® Forums

Toad continues to try to logon on to Team Foundation [Beta 13.0.0.66 x64]


#1

I have ended connection to Team Foundation. Logging on with Toad, our designated administrator schema, I disabled Team Coding on the database and set VCS Provider to “none”.

However, every time I start up Toad, it comes up with the Team Foundation logon request. (this also now happens with Toad 12 so it may or may not have been caused by the beta)

Note: I just noticed that if I start up TOAD with no session logged in, it seems to be defaulting to Team Foundation server (3rd pic).

OK. That cleared it. Somehow, it continued to default to Team Foundation server and tried to logon before even getting connected to any database via session logon. Without logging on to a session, I opened team coding, selected VCS provider “none”, and then clicked Apply and then OK. Now the bare TOAD startup is not asking for logon and when I open the Team Coding window it lists “none” as the VCS provider choice.

  1. Team Configuration cleared

  2. logon request keeps appearing

  3. However, even with no session, this seems to be the default on Team Coding now


#2

Hey Douglas,

The Team Coding configuration window is designed to control both database-controlled (team) settings as well as local settings (for file-based, manual source control). When you’re connected to a database, it will load the database configuration. When you’re not connected to a database, it will load your local settings. Most likely, at some point, you had set TFS as your default local VCS provider when you weren’t connected to a database.

As for the TFS login dialog, this is normal. TFS has made various minor changes to its API over the years. As a result, Toad needs to perform some initial queries against TFS in order to determine which version of TFS is installed. The act of querying those interfaces cause the authentication dialog to display. Since TFS is based on NT Authentication, this is expected.

If you don’t want TFS’ login dialog to prompt initially upon Toad loading, I’d simply make sure that no local VCS provider is selected.

Hope that helps!

-John


#3

Thanks John!