Toad World® Forums

Toad Data Point 3.5 not running Macros in Automation


#1

I cant get macros to display in TDP 3.5 when automating reports. I have had to stop using 3.5 and revert to 3.4 as stakeholders are depending on my daily reports.

Is this a known issue?


#2

Yes, this is known issue. The fix did not make it into the GA release. Please download and use this build. Download Base or Pro according to the license you own.

community-downloads.quest.com/…/ToadDataPoint_Base_3.5.0.2936.zip

community-downloads.quest.com/…/ToadDataPoint_pro_3.5.0.2936.zip


#3

Does any of those have the fix for mangled Excel spreadsheets that used a macro that was run from TDP?


#4

I am not sure what you are referring to. Do you have a Excel file that got corrupted after using TDP export? Please provide details so we can address. Or have this been discussed in another post?


#5

It was a discussion and was confirmed by developers since version 3.1. I have tried every version since then and I still must use 3.0 to use the export with macros to not get a mangled Excel file. I recently tried again to move to 3.4 when switching to a whole new PC and it scrambled the files as well.


#6

I have been tracking macros since 3.1. We have had several issues with them. All of them different. Mangled files always have to do with a third party vender we use. But once we send them the file they fix the issues. So to know which issue this is i would need you to send me a copy of your xlsm file.


#7

would you like us to pursue this? If so send your files and details to debbie.peabody@quest.com


#8

Debbie, I’m not sure what happened but I was debugging in task scheduler yesterday and today it seems to be working… I have no clue what I changed but it seems ok.

Thanks for the help!

Neil