Toad World® Forums

Toad Data Point Insert Query Issue

We are attempting to use TDP to load 30M+ records from a file export from Oracle and then loading the data into Teradata. However, if we use the import wizard it is maxing out the spool capacity we have and we need to know if the wizard is executing multiple inserts and if so how we minimize that so we're not pushing the available spool capacity which results in a system abort when we hit threshold. We know there is a fetch threshold in the options, perhaps that is what is happening with the insert and we need to increase it?

image

Hi,
I'm really not sure Toad has been made with such large numbers in mind. We did some tasks with 10M databases maximum, I personally tried with 10M of inserts and it worked fine and reasonably quickly. Generally it's recommended to keep it under a milion of records.
I'll consult the devs if they know of any specific limitation for Teradata imports.

Hi,

import wizard execute multiple insert statements with bloc size. You should be able to set this block before you start the Import. In your case you should disable 'Optimize bloc size' and try to specify some of your limits.

Thanks, that will help greatly.

I updated the block size, which was set to optimize, and noticed the insert row count was the same as when it was set to optimize. How can we confirm the block size is as specified? It appears to be updating in increments of 10K in the background processes. This is key to reducing the number of queries executed that pushes our present spool capacity.