Toad World® Forums

Toad for Oracle 12.1: PLSQL-Code with Cursor: Within Cursor: Shift-Enter: How to disable "Edit SQL" window ?

Toad for Oracle 12.0 or 12.1:

When editing PLSQL-Code with a Cursor with subselects:

Then press within Cursor lines: Shift-Enter: Then it appears an “Edit SQL” window, and after OK I need to put in lots of variables(with complex Cursor SQL), then OK again to execute SQL.

So there exist no more possibility to just press Strg+Enter when editing PLSQL code and between cursor lines like it works with Toad for Oracle 11.6. Very pity: My workaround with Toad 12: I need to mark the Cursor, put it in a new tab (Strg-C/Strg-V) and execute then.

Because some colleagues and me need this very often we did deinstall Toad 12 and reinstall Toad 11.6 again !

Therefore my question: Exist any possibility with Toad 12 to disable this new feature “Edit SQL” ? Or is it planned in further Toad for Oracle versions ?

I suggest one another option when “Edit SQL” has popped up: Another button “Original SQL without variables”, and after OK it would result same like Strg-Enter direkt with Toad 11.6.

Toad is trying to intelligently execute that SQL by converting references to PL/SQL identifiers into bind variables and stripping any INTO and RETURNING clause. It sounds like in your case it’s making binds where there should not be. For 12.5 it’s gotten better although there are still a couple of outstanding issues that I’m working on. If you’d like to email me your cursor SQL as well as the SQL that appears in the Edit SQL dialog after Shift+F9 I’ll take a look.

michael.staszewskiquest.com