Toad World® Forums

Toad for Oracle - Create Index Icon grayed out when using Team Coding

In Toad for Oracle, why is the ‘Create Index Icon’ greyed out when viewing the the properties for a table? This happens in TFO 12.8 and 12.9 when accessing an Oracle 10 or Oracle 11 databases? I have installed Team Coding and I am connecting to a Team Foundation Source control server for VCS.

Are you in the Schema Browser? If so, it should be enabled as long as only one table is selected, and it’s not an external table, and Toad isn’t in read-only mode, and it’s not being blocked by Toad Security.

If you aren’t in the Schema Browser, let me know exactly where you are in Toad (or post a screen shot).

Thanks,

John D.

I was in Schema Browser, one table selected, it was not an external table.

I’m not sure about Toad being in ‘Read Only’ mode, the object was under source control but was checked out to me, should be writable. Also not sure about Toad security blocking these functions, Toad seems to allow other create functions, create table icon works, delete table from right click dialog works.

I uninstalled Team Coding and the functions returned to normal.

Give me a bit and I will post a screen shot…

Oh, I found it -

You must be on the RHS “Index” tab. I see how that one is going to be affected by Team Coding. If you right-click on the table on the left, then choose “Add -> Index”, that one should be enabled. It’s a bug that it’s disabled on the right. I’ll fix it.

-John

Yes, right clicking on the table and navigating to the Add->Index options brings up the Create Index window and everything seems to be working from there, thanks and kudo’s for the very quick response.