Toad World® Forums

Toad: Table Autocomplete Functionality Not Working


#1

I’ve been using Toad for more than a year now without problems. All of a sudden the table autocomplete feature has ceased working. No settings have been changed, and I’ve clean installed a new TOAD version, yet the problem persists.

The image below shows autocomplete defaulting into view IN_INSTRUMENT in schema MCDM. Normal behaviour should result in a table/view list.

It is notable that the above does not happen with all schemas. For some schemas I will still see a table list. In the beginning this error happened only with a single schema. Now it is slowly progressing to other schemas as well, which is exceptionally frustrtating when you’re dealing with dozens of schemas that contain hundreds of tables each. It slows down development when you must open Schema Browser and look for the exact table/view/procedure/package each time instead of letting autocomplete give suggestions.

As can be seen from Code Assist settings, these should be in order.

How to reset autocomplete behaviour into what is its original state?


#2

Maybe you had option for “Check for DBA Views” under startup checked and somehow unchecked it???

From: xre [mailto:bounce-xre@toadworld.com]

Sent: Friday, January 03, 2014 3:46 AM

To: toadoracle@toadworld.com

Subject: [Toad for Oracle - Discussion Forum] Toad: Table Autocomplete Functionality Not Working

Toad: Table Autocomplete Functionality Not Working

Thread created by xre

I’ve been using Toad for more than a year now without problems. All of a sudden the table autocomplete feature has ceased working. No settings have been changed, and I’ve clean installed a new
TOAD version, yet the problem persists.

The image below shows autocomplete defaulting into view IN_INSTRUMENT in schema MCDM. Normal behaviour should result in a table/view list.

It is notable that the above does not happen with all schemas. For some schemas I will still see a table list. In the beginning this error happened only with a single schema. Now it is slowly
progressing to other schemas as well, which is exceptionally frustrtating when you’re dealing with dozens of schemas that contain hundreds of tables each. It slows down development when you must open Schema Browser and look for the exact table/view/procedure/package
each time instead of letting autocomplete give suggestions.

As can be seen from Code Assist settings, these should be in order.

How to reset autocomplete behaviour into what is its original state?

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


#3

Nope - this is still checked.


#4

Significant changes to this feature were recently implemented. Looks like a bug. I’ll try to reproduce here.

Michael

On 01/03/2014 04:46 AM, xre wrote:

Toad: Table Autocomplete Functionality Not Working

Thread created by xre
I’ve been using Toad for more than a year now without problems. All of a sudden the table autocomplete feature has ceased working. No settings have been changed, and I’ve clean installed a new TOAD version, yet the problem persists.

The image below shows autocomplete defaulting into view IN_INSTRUMENT in schema MCDM. Normal behaviour should result in a table/view list.

It is notable that the above does not happen with all schemas. For some schemas I will still see a table list. In the beginning this error happened only with a single schema. Now it is slowly progressing to other schemas as well, which is exceptionally frustrtating
when you’re dealing with dozens of schemas that contain hundreds of tables each. It slows down development when you must open Schema Browser and look for the exact table/view/procedure/package each time instead of letting autocomplete give suggestions.

As can be seen from Code Assist settings, these should be in order.

How to reset autocomplete behaviour into what is its original state?

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


No virus found in this message.

Checked by AVG - www.avg.com

Version: 2014.0.4259 / Virus Database: 3658/6963 - Release Date: 12/31/13


#5

In your first screenshot how are you getting the popup to open? Are you simply typing your schema name followed by a period and waiting for the popup to open automatically or are you manually opening it with CTRL+T? Is it reproducible 100% of the time with
the example that you show? Are you logged in as a schema other than MCDM? So far I’ve been unable to reproduce it locally. I have my Code Assist options set as you show in the screenshot.

Michael

On 01/03/2014 04:46 AM, xre wrote:

Toad: Table Autocomplete Functionality Not Working

Thread created by xre
I’ve been using Toad for more than a year now without problems. All of a sudden the table autocomplete feature has ceased working. No settings have been changed, and I’ve clean installed a new TOAD version, yet the problem persists.

The image below shows autocomplete defaulting into view IN_INSTRUMENT in schema MCDM. Normal behaviour should result in a table/view list.

It is notable that the above does not happen with all schemas. For some schemas I will still see a table list. In the beginning this error happened only with a single schema. Now it is slowly progressing to other schemas as well, which is exceptionally frustrtating
when you’re dealing with dozens of schemas that contain hundreds of tables each. It slows down development when you must open Schema Browser and look for the exact table/view/procedure/package each time instead of letting autocomplete give suggestions.

As can be seen from Code Assist settings, these should be in order.

How to reset autocomplete behaviour into what is its original state?

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


No virus found in this message.

Checked by AVG - www.avg.com

Version: 2014.0.4259 / Virus Database: 3658/6963 - Release Date: 12/31/13


#6

Hi Michael,

In this example I am typing the schema name followed by a period and waiting for the pop to open automatically. The same issue exists when using CTRL+T after the period. If I write only MCDM (i.e. without the period) and then press CTRL+T, I get an expandable list of tables and views correctly.

It is reproducable 100% of the time on this schema and a number of other ones.

I am not logged on the MCDM schema, but appropriate rights and grants have been given to the schema I am logged on (moreover, it is a generic user that is also used by my colleagues and they are not experiencing this problem).

Thanks.


#7

Thanks. Can you send your toad.ini to me offline?
michael.staszewski@quest.com

Michael

On Jan 6, 2014, at 2:12 AM, “xre” bounce-xre@toadworld.com wrote:

RE: Toad: Table Autocomplete Functionality Not Working

Reply by xre
Hi Michael,

In this example I am typing the schema name followed by a period and waiting for the pop to open automatically. The same issue exists when using CTRL+T after the period. If I write only MCDM (i.e. without the period) and then press CTRL+T, I get an expandable
list of tables and views correctly.

It is reproducable 100% of the time on this schema and a number of other ones.

I am not logged on the MCDM schema, but appropriate rights and grants have been given to the schema I am logged on (moreover, it is a generic user that is also used by my colleagues and they are not experiencing this problem).

Thanks.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


#8

I’ve sent you a mail with the file, thanks.


#9

Got it, thanks. I’m still unable to reproduce. If you can download/install the beta you can try there as much work has been done to this feature in recent weeks.
If not, you can try to create a new set of user files using the Utilities|Copy User Settings menu item. Select the create clean set of user files option. This will mimic a new install on a clean machine. Before doing so I’d backup your entire appdata folder.
Its location can be found in the Options|General|Application data directory control. You mentioned installing a new version of Toad, but if this is on the same machine as an older version and you did not uninstall the old first your old settings were migrated
automatically so any corruption in configuration files would be brought over as well.

From: xre [mailto:bounce-xre@toadworld.com]

Sent: Monday, January 06, 2014 9:32 AM

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] Toad: Table Autocomplete Functionality Not Working

RE: Toad: Table Autocomplete Functionality Not Working

Reply by xre

I’ve sent you a mail with the file, thanks.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


No virus found in this message.

Checked by AVG - www.avg.com

Version: 2014.0.4259 / Virus Database: 3658/6975 - Release Date: 01/04/14


#10

Hi Michael,

I’ve done the above. Doing a clean set of user files fixed the issue - so it must have been a corrupt configuration file as you mentioned. Many thanks for your help!!


#11

Code assist worked for a few days after a clean install of Toad 12.6.0.53 and has slowly fizzled out and stopped working. I’ve tried all the things in this thread to no avail. I tried running Toad as a windows Admin user ID and code assist worked for all of about an hour and has stopped working.

Any thoughts or suggestions?

Thank you in advance for your assistance.


#12

Hi all,

I’ve tried to do the above. I also reset autocomplete behaviour. I’ve been using Toad for more than a month now without problems. All of a sudden the table autocomplete feature has ceased working. No settings have been changed. Now, I can use autocomplete behaviour via wrong. When I press the CTRL+T (or CTRL+.), I can show only one table. How can I solve this problem? Do you have any suggestions?


#13

Can you send a sample statement, preferably one using common SCOTT objects or the data dictionary?

If it’s specific to your SQL then post a screenshot of your editor text or send the entire contents of your editor and indicate where the caret is located. You can send to me offline if you want if the info is sensitive. michael.staszewskiquest.com

Michael

On 09/08/2015 06:51 AM, missfibonacci wrote:

RE: Toad: Table Autocomplete Functionality Not Working

Reply by missfibonacci
Hi all,

I’ve tried to do the above. I also reset autocomplete behaviour. I’ve been using Toad for more than a month now without problems. All of a sudden the table autocomplete feature has ceased working. No settings have been changed. Now, I can use autocomplete behaviour via wrong. When I press the CTRL+T (or CTRL+.), I can show only one table. How can I solve this problem? Do you have any suggestions?

To reply, please reply-all to this email.

Stop receiving emails on this subject.
Or Unsubscribe from Toad for Oracle - General notifications altogether.
Toad for Oracle - Discussion Forum

Flag this post as spam/abuse.