Toad World® Forums

ToadforDB2 error message, when toad opened

Hi;
We use toad for dB2 in our company from Appv (Microsoft Application Virtualization). we got some error message, when toad opened. error message screenshot attached. it look like warning because we click OK button than toad is wroking properly. But I could not figure out this error mesagge what this is. this error message irritate user. I want to solve this problem.
Is there any one how handle this problem? I am really need help..
thanks your attention.

It appears that Toad is erroring in its document recovery feature.
Are all users having this issue or just one?
What Windows Operating system are you using?
What version of Toad DB2 are you using?
Does each Toad user have the authority to read\write to their Toad Application Data directory (see below for location)?

Perhaps Toad was abnormally shutdown once when some SQL Editor documents were opened or perhaps there are issues with the application data directory Toad uses to store settings, etc. To resolve this issue you can attempt to remove old recovery documents.

  1. Start Toad - and open Help - About.
  2. Then click on the Application Data directory link to open that directory.
  3. Close Toad.
  4. Back in the Windows explorer of the Appllication Data directory, navigate to the Document Recovery directory - on Windows XP it will be similar to:

C:\Documents and Settings<user>\Application Data\Quest Software\Toad for DB2 4.7\Document Recovery

Are there any files in that directory?
If so you can delete those and then delete the Document Recovery directory.

  1. After deleting the Document Recovery directory restart Toad.
  2. You can turn off the Document Recovery feature in Toad by navigating to:
    Tools |Options | Environment | General - and uncheck the ‘Save document files for automatic recovery’ checkbox.

(You will have to repeat these steps for each user having this issue).
Hope this helps

Hi jeff.podlasek;
firstly; I can not say all user having this issue because I can open toad properly but most user cannot open it. this error message have appeared (screenshot above). I am tried it on diffrent user computer and most of user saw this error message,when toad opened.
secondly, we use Windows 7 Enterprise operating system in our company
thirdly, we have used TOAD 4.7 than we said this issuse TOAD distributor in Turkey and they sent us new version TOAD 5.0 did not change anything. User got same error message, when toad opened.
fourthly, yes, user that use toad own pc have local admin and they can access that directory.
I dont think Toad was abnormally shutdown because I checked, when user run toad first time they got this error message.
last one, I checked that directory (C:\Users<userId>\AppData\Roaming\Quest Software\Toad for DB2 4.7) and ý cant saw Document Recovery directory. ýn this way, there are Context, Data, Layouts, ModuleSettings, Session, SQLFormatter, Templates, Action.log, connections.xml, Settings.xml and there is not Document Recovery directory.
I triy these steps what you said, but it is not solve this issuse and important thing is we use TOAD form APP-V (Microsoft Application Virtualization) not standalone.
I realy need help about this issuse…
thanks your attention…

Thanks for the information.
Sorry to hear that those steps outlined did not assist.

Does each seperate user have his or her own unique Application Data directory or are users sharing one of those?

Did you have the user(s) who had this issue turn off automatic document recovery via:
Tools |Options | Environment | General - and uncheck the ‘Save document files for automatic recovery’ checkbox…and then restart Toad?

I would highly suggest that you open a support ticket at support.quest.com so our support organization can open a support case where all pertinent information can be captured and be trackable.
thanks