Truncating Column Names

IN Toad Data Point - - in the Build query box, if i have a table/view with a long column name it will truncate the column to 30 characters.
column name = cumulativeNonRecoverableInterest
truncated name = cumulativeNonRecoverableIntere

How do I stop this. The query will not run - it gives the error the field does not exist.
I can query just fine in Edit mode.

Hey Jim,

I'm not seeing this in my limited testing, not with my mainstream relational databases anyway (SQL Server, Oracle, etc.)

Can you share what data source/version you're trying to build the query for? Can you share a screen snap?

Also, see if this option might help: