Turn off formatter in Toad data point

Sort of having a sinking feeling about this. Doesnt look like i can do this.

I work in multiple environments where the queries are the same or very close, especially between sql server and Oracle. i have some very complex joins and subquiries with comments placed ins specific places and i rely heavily on alignment for reviewing my work.

It looks like Toad Data point has decided how it wants to format my stuff and i can find no way to simply turn it off. i have one very complex and heavily documented view that when i pull it up in datapoint, it is completely unreadable and also it tells me the sql is invalid in a number of places.

This has gotten to the point where i am using SQL Developer for a lot of work and only using datapoint for some reports/selects.

Is there a way to totally turn this off?

I am sorry but you are right there is no way to turn formatting off. I created a task QAT-1811 about it.

In the meantime you could try the custom formatting. Go to Tools|Options|Editor|Formater and select the Custom tab. There you could set formatting rules for different syntax elements.

Also you could post a statement that has preferable formatting. Maybe we‘ll be able to create a custom one for you.



thats what i feared and thats seems crazy to me that you are forced to use formatting.

and yes i can get a bit close with adjustments but it is absolutely imperative that some of my work remain formatted as it is.

if you using this product in an environment with may other users using other tools and across multiple databases with specific formatting requirements and storing complex scripts in central source control systems it would seem to limit the potential for this product to be used in such situations.

simply turn it off. is that a difficult modification to make to the product.?


simple bottom line. it prevents me from using this product as my main db tool. and im forced to use sql developer for oracle stuff for its ability to not munge my complex SQL scripts…