Unable to edit/delete row in table


Hi All,
When I am trying to edit a particular table in Toad and trying to select and delete a row, I am getting the above error. When tried to do the same thing from friends system , same is happening. Please help to resolved the issue.

additional details:
toad version: 9.6.1
oracle version: oracle 9i
--table is normal table with varchar2 and number datatype columns
-- I have tried edit query and selected the row then tried delete option, tried update query, both are failing with same error

*** When checked I am able to add and delete using insert and delete command, but other ways its not working.

Welcome to the Toad for Oracle forum, btw.

It's always (always) good to put as much detail as possible when posting questions or describing issues. These things would be good to know:

  • Toad version/edition?
  • Oracle version/edition?
  • Anything unusual about the table? (partitioned, LOBs present, etc.)
  • How were you trying to update the data? (e.g. via Schema Browser? with script in Editor?)
  • Can you outline the steps so the ToadWorld community can reproduce? Screen snapshots or short videos go a long way here.

Otherwise, might be wise to take this to Quest Support, please.

Hi @Gary.Jerep ,
I am new to this forum, thanks for the suggestions, please check the updated question I have added the details. Also when trying to add row in table I am getting the same error but after after clicking ok, row is getting updated in table. But for deleting I am unable to to it. Please help.

Toad 9.6! Wow!

That version is very old. I really have no idea what caused that error.

If it happens again, click where it says "Click here". Another dialog will show. On the next dialog, if there is a "copy to clipboard" box, then check it and click OK. That will put the error log in your clipboard and you can paste it here.

If you don't have the "copy to clipboard" box, then go to the tab labelled "call stack", and do a manual copy out of there, and paste it here.