Toad World® Forums

Unhandled exception when starting the program


#1

After the installation the program worked fine, but after once finished, now every attempt to start the program breaks with the error message “An unhandled exception occurred: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt”.
Even a deinstallation and new installation did not solve the problem.

Backup Reporter Exceptions.zip (27.2 KB)


#2

Is it possible for you to mark the Database not to connect at startup? Might be just one DB causing the issue.

Just a thought…


#3

Thank you for reporting the issue.


#4

Yes, there is a way to skip the connection, but it may not solve your issue.
In the config.xml file, set true to false.
You can also remove the connection completely by remove the node.


#5

A new version of Backup Report is available. We believe it should fix this issue.

Thank you


#6

I have downloaded and installed the newversion (1.0.58.121), but the issue is not solved by that, same Unhandled Exception, when starting the program as before.


#7

I have downloaded and installed the newversion (1.0.58.121), but the issue is not solved by that, same Unhandled Exception, when starting theprogram as before.


#8

A new version, 1.0.60.123, is available.
We believe it should fix this issue.
Thank you


#9

Better but not 100% ( I am running the latest version 1.0.60.123 )

I can now login and see the db but it fails with the same problem on the Backups tab.

Hope you can fix this one too…

Love the product! Just need to iron out the bugs.


#10

Can you send us the exception report?
It will help us find the issue.
Thank you


#11

exception detail attached when clicking the “backups” tab (as requested) for version 1.0.60.1234 1.0.60.123


#12

exception detail attached when clicking the “backups” tab (as requested) for version 1.0.60.1234 1.0.60.123


#13

exception detail attached when clicking the “backups” tab (as requested) for version 1.0.60.1234 1.0.60.123
environment.txt (1.86 KB)


#14

I also have the unhandled exception when I attempt to start qbr.
exception_info.txt (2.75 KB)


#15

I also have the unhandled exception when I attempt to start qbr.
environment.txt (1.99 KB)


#16

One possible cause for this message is that the computer registry contains invalid information about the regional settings. There is a rare Microsoft bug that will set the following registry value:

HKEY_CURRENT_USER\Control Panel\International\sPositiveSign

This value should always be set to an empty string.

If the registry value is not empty, the resolution is to go to Control Panel-> Regional and Language Options -> Standards and formats setting. Change it from its current setting to a different language and back again. This should reset the relevant registry options.


#17

Hi

My registry setting was empty so I guess its not this.


#18

Even though the setting looks correct, can you try setting the setting to something different and then resetting them?

Thank you


#19

Hi Elisa

Sorry that didn’t help - let me know if you want me to try anything else.

Ian.


#20

Changing my language setting and changing it back kinda worked for me. The software opens at least but crashes with another error(s). I don’t mean to hijack the thread. I’ll open another thread for the additional errors.