Toad World® Forums

Upgraded to Excel 2013 - Mow TDA 3.0 is saying 'Excel file in use' when trying to export.

I upgraded to Excel 2013 and now all scripts that use a Export and access a macro says the file is in use. This was a forced upgrade company-wide.

I MUST USE TDA 3.0 because of the mangled excel export issue. The file isn’t open by any other process.

Here’s what is sent:

Automation script “XOG_SE_Dashboard_TEST” had errors while executing. The exception messages are listed below and the log file is attached.

Continue on Error Exception Messages:

Export_Excel_TDA30 - The process cannot access the file ‘C:~TDA30_ByProject\SE_Dashboard\SE_Dashboard.xlsm’ because it is being used by another process.

To Peter.D.Maxwell:

Thank you for posting in Toad World. We humbly apologize for the inconvenience.

I would like to know more about the "mangled excel" export issue that exists in our newest products. Any information you are able to provide, including reproduction steps, a copy of the automation script, a copy of the excel file, and especially a Toad Support Bundle, would be extremely helpful in resolving this issue.

To Create A support Bundle and post it

  1. Launch Toad Data Point through the shortcut with the parameter /log=all.

  2. A new tab will appear. After it's done generating the bundle, Right-click the tab -> Save File to save the .zip file to any directory of your choosing.

  3. Return to the Toad World thread and Post a Reply using Rich Formatting

  4. Compose a message

  5. Select the Options tab next to Compose, then click Click to Add to add the .zip support bundle

  6. Post when you're ready!

To help verify the file being not in use, I would like to recommend using Process Monitor to capture more detailed activity of a particular item.

Using Process Monitor

  1. Download Process Monitor: http://technet.microsoft.com/en-us/sysinternals/bb896645
  2. Launch Process Monitor
  3. Push the "Filter" button
    AddAFilter.png
  4. Specificy filtering conditions down to only activities involving your particular file.
    ie: Path contains C:~TDA30_ByProject\SE_Dashboard\SE_Dashboard.xlsm' then Include
  5. It will filter all the events to show actions a process is doing directly to a particular file.
    Example.png
  6. This can definitely show when and how a file is in use by a process.
    We look forward to information regarding the mangled excel export issue.

Software Associate Developer I,
-Joshua Liong

Here’s the original case:


Please retain this in all replies: CaseID:1061059

Note: only responses above this line will be added to the case

Quest Support: jon_lin

Case Title: TDA 3.1 does not handle Macro in Excel properly.


I’m extremely frustrated - I was told that this was fixed multiple times and tried doing an upgrade multiple times wasting a ton of my time. I actually gave up on getting a fix. Now that I must upgrade to Excel 2013 I MUST get a fix!!! I will also reply with the support bundle soon.

Keep in mind that Case 1061059 was opened in Aug 2013.

OOPS. August 2012. Yeah, I’m a bit upset.


Support Bundle: Toad for Data Analysts 3.0.1.1734 Professional Edition
5/17/2014 11:15:06 AM



System Information


Operating System
Microsoft Windows 7 Enterprise 6.1.7601 AMD64
Manufacturer: Microsoft Corporation
Computer Name: TXPLANPDMAXWEL1
Windows Directory: C:\Windows

Computer System
Computer Manufacturer Name: Dell Inc.
Computer Model: OptiPlex 7010
System Type: x64-based PC
Total Physical Memory: 4,078,032 KB
Domain: corp.inthosts.net
User Name:

System Processor
Manufacturer: GenuineIntel
Computer Processor: Intel64 Family 6 Model 58 Stepping 9
CPU Speed: 3.3 GHz
L2 Cache Size: 1 KB

System Bios
BIOS: BIOS Date: 12/23/13 09:56:28 Ver: A17.00
BIOS Version: DELL - 1072009

System Time Zone
Time Zone: (UTC-06:00) Central Time (US & Canada)

Logical Memory Configuration


Connection Information


Current Connection:
MATISSE.CORP.INTHOSTS.NET (INFOSTORE_REPORT), INFOSTR
Category: Production
Oracle database
Server version 11.2.0.2 (NONDBA)
Connected since 5/17/2014 11:12:16 AM
0 of 2 connections in pool active
Server version:
Oracle Database 11g Release 11.1.0.0.0 - Production
Database NLS settings:
NLS_Language =AMERICAN
NLS_Territory =AMERICA
NLS_CharacterSet =WE8MSWIN1252

Instance NLS settings:
NLS_Language =AMERICAN
NLS_Territory =AMERICA

OS current culture info:
English (United States)
Connection mode:
OCI connect.
Client version: 9.2.0.1
Oracle Homes:
OraHome92 Path=C:\oracle\ora92 NLS_LANG=NA

Oracle Default Home:
Default Home: OraHome92
Path = C:\oracle\ora92
NLS_LANG = NA

Registry Structure:
HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE
API= C:\oracle\ora92\dbs
inst_loc= C:\Program Files (x86)\Oracle\Inventory
NLS_LANG= NA
ORACLE_GROUP_NAME= Oracle - OraHome92
ORACLE_HOME= C:\oracle\ora92
ORACLE_HOME_NAME= OraHome92
HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\ALL_HOMES
DEFAULT_HOME= OraHome92
HOME_COUNTER= 1
LAST_HOME= 0
HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\ALL_HOMES\ID0
NAME= OraHome92
NLS_LANG= NA
PATH= C:\oracle\ora92
HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\HOME0
ID= 0
MSHELP_TOOLS= C:\oracle\ora92\MSHELP
NLS_LANG= AMERICAN_AMERICA.WE8MSWIN1252
ORACLE_BUNDLE_NAME= Enterprise
ORACLE_GROUP_NAME= Oracle - OraHome92
ORACLE_HOME= C:\oracle\ora92
ORACLE_HOME_KEY= Software\ORACLE\HOME0
ORACLE_HOME_NAME= OraHome92
SQLPATH= C:\oracle\ora92\dbs
HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\Workflow
Icon Directory= C:\oracle\ora92\WF\ICON
Level= 100
Version= 2.6.1.5.2
HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\Workflow\Font
HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\Workflow\Languages
HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\Workflow\Languages\ENU
Data= C:\oracle\ora92\WF\DATA\us
Message= C:\oracle\ora92\WF\RES\WFus.RES
TemplateDir= C:\oracle\ora92\WF\DATA\us

Connection:
TXPLANPDMAXWEL1 (CORP\pdmaxwell), master
SQL Server database
Server version 11.0.2100.60
Connected since 5/17/2014 11:13:03 AM
0 of 1 connection in pool active


Loaded Assemblies


{4b4f4023-093e-4fac-a3ba-e4fd0bbf837c}, Version=0.0.0.0, Culture=neutral, PublicKeyToken=3e56350693f7355e
Accessibility, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a C:\Windows\assembly\GAC_MSIL\Accessibility\2.0.0.0__b03f5f7f11d50a3a\Accessibility.dll
ActiproSoftware.Shared.Net20, Version=1.0.104.0, Culture=neutral, PublicKeyToken=36ff2196ab5654b9 C:\Windows\assembly\GAC_MSIL\ActiproSoftware.Shared.Net20\1.0.104.0__36ff2196ab5654b9\ActiproSoftware.Shared.Net20.dll
ActiproSoftware.SyntaxEditor.Net20, Version=4.0.287.0, Culture=neutral, PublicKeyToken=21a821480e210563 C:\Windows\assembly\GAC_MSIL\ActiproSoftware.SyntaxEditor.Net20\4.0.287.0__21a821480e210563\ActiproSoftware.SyntaxEditor.Net20.dll
ActiproSoftware.UIStudio.Dock.Net20, Version=2.0.111.0, Culture=neutral, PublicKeyToken=be939c973e8cb8a6 C:\Windows\assembly\GAC_MSIL\ActiproSoftware.UIStudio.Dock.Net20\2.0.111.0__be939c973e8cb8a6\ActiproSoftware.UIStudio.Dock.Net20.dll
ActiproSoftware.WinUICore.Net20, Version=1.0.104.0, Culture=neutral, PublicKeyToken=1eba893a2bc55de5 C:\Windows\assembly\GAC_MSIL\ActiproSoftware.WinUICore.Net20\1.0.104.0__1eba893a2bc55de5\ActiproSoftware.WinUICore.Net20.dll
Devart.Data, Version=5.0.187.0, Culture=neutral, PublicKeyToken=09af7300eec23701 C:\TDA30\Plugins\MySQL\Devart.Data.dll
Devart.Data.Oracle, Version=6.0.86.0, Culture=neutral, PublicKeyToken=09af7300eec23701 C:\TDA30\Plugins\Oracle\Devart.Data.Oracle.dll
DevExpress.BonusSkins.v10.2, Version=10.2.3.0, Culture=neutral, PublicKeyToken=95fc6c5621878f0a C:\Windows\assembly\GAC_MSIL\DevExpress.BonusSkins.v10.2\10.2.3.0__95fc6c5621878f0a\DevExpress.BonusSkins.v10.2.dll
DevExpress.Data.v10.2, Version=10.2.3.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a C:\Windows\assembly\GAC_MSIL\DevExpress.Data.v10.2\10.2.3.0__b88d1754d700e49a\DevExpress.Data.v10.2.dll
DevExpress.OfficeSkins.v10.2, Version=10.2.3.0, Culture=neutral, PublicKeyToken=95fc6c5621878f0a C:\Windows\assembly\GAC_MSIL\DevExpress.OfficeSkins.v10.2\10.2.3.0__95fc6c5621878f0a\DevExpress.OfficeSkins.v10.2.dll
DevExpress.PivotGrid.v10.2.Core, Version=10.2.3.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a C:\Windows\assembly\GAC_MSIL\DevExpress.PivotGrid.v10.2.Core\10.2.3.0__b88d1754d700e49a\DevExpress.PivotGrid.v10.2.Core.dll
DevExpress.Utils.v10.2, Version=10.2.3.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a C:\Windows\assembly\GAC_MSIL\DevExpress.Utils.v10.2\10.2.3.0__b88d1754d700e49a\DevExpress.Utils.v10.2.dll
DevExpress.XtraBars.v10.2, Version=10.2.3.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a C:\Windows\assembly\GAC_MSIL\DevExpress.XtraBars.v10.2\10.2.3.0__b88d1754d700e49a\DevExpress.XtraBars.v10.2.dll
DevExpress.XtraEditors.v10.2, Version=10.2.3.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a C:\Windows\assembly\GAC_MSIL\DevExpress.XtraEditors.v10.2\10.2.3.0__b88d1754d700e49a\DevExpress.XtraEditors.v10.2.dll
DevExpress.XtraGrid.v10.2, Version=10.2.3.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a C:\Windows\assembly\GAC_MSIL\DevExpress.XtraGrid.v10.2\10.2.3.0__b88d1754d700e49a\DevExpress.XtraGrid.v10.2.dll
DevExpress.XtraNavBar.v10.2, Version=10.2.3.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a C:\Windows\assembly\GAC_MSIL\DevExpress.XtraNavBar.v10.2\10.2.3.0__b88d1754d700e49a\DevExpress.XtraNavBar.v10.2.dll
DevExpress.XtraReports.v10.2, Version=10.2.3.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a C:\Windows\assembly\GAC_MSIL\DevExpress.XtraReports.v10.2\10.2.3.0__b88d1754d700e49a\DevExpress.XtraReports.v10.2.dll
DevExpress.XtraReports.v10.2.Extensions, Version=10.2.3.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a C:\Windows\assembly\GAC_MSIL\DevExpress.XtraReports.v10.2.Extensions\10.2.3.0__b88d1754d700e49a\DevExpress.XtraReports.v10.2.Extensions.dll
DevExpress.XtraTreeList.v10.2, Version=10.2.3.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a C:\Windows\assembly\GAC_MSIL\DevExpress.XtraTreeList.v10.2\10.2.3.0__b88d1754d700e49a\DevExpress.XtraTreeList.v10.2.dll
DevExpress.XtraVerticalGrid.v10.2, Version=10.2.3.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a C:\Windows\assembly\GAC_MSIL\DevExpress.XtraVerticalGrid.v10.2\10.2.3.0__b88d1754d700e49a\DevExpress.XtraVerticalGrid.v10.2.dll
FastData, Version=6.0.0.1734, Culture=neutral, PublicKeyToken=c862883b2ae69822 C:\TDA30\FastData.dll
IBM.Data.DB2.9.7.2, Version=9.7.2.2, Culture=neutral, PublicKeyToken=7c307b91aa13d208 C:\TDA30\SQLLIB\bin\netf20\specific\IBM.Data.DB2.9.7.2.dll
ICSharpCode.SharpZipLib, Version=0.85.5.452, Culture=neutral, PublicKeyToken=1b03e6acf1164f73 C:\TDA30\ICSharpCode.SharpZipLib.dll
MailBee.NET, Version=6.5.2.236, Culture=neutral, PublicKeyToken=cd85b70fb26f9fc1 C:\Windows\assembly\GAC_MSIL\MailBee.NET\6.5.2.236__cd85b70fb26f9fc1\MailBee.NET.dll
ManagedQP5, Version=5.2.5.1734, Culture=neutral, PublicKeyToken=c862883b2ae69822 C:\TDA30\managedqp5.dll
Microsoft.mshtml, Version=7.0.3300.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a C:\Windows\assembly\GAC\Microsoft.mshtml\7.0.3300.0__b03f5f7f11d50a3a\Microsoft.mshtml.dll
Microsoft.Office.Interop.Excel, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c C:\Windows\assembly\GAC_MSIL\Microsoft.Office.Interop.Excel\15.0.0.0__71e9bce111e9429c\Microsoft.Office.Interop.Excel.dll
Microsoft.SqlServer.Types, Version=10.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91 C:\Windows\assembly\GAC_MSIL\Microsoft.SqlServer.Types\10.0.0.0__89845dcd8080cc91\Microsoft.SqlServer.Types.dll
mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089 C:\Windows\Microsoft.NET\Framework\v2.0.50727\mscorlib.dll
msvcm90, Version=9.0.30729.4974, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a C:\Windows\WinSxS\x86_microsoft.vc90.crt_1fc8b3b9a1e18e3b_9.0.30729.4974_none_50940634bcb759cb\msvcm90.dll


Licensing


ToadSupportBundleToad for Data Analysts.zip (1.88 MB)

I got this to run without error! It seems to have something to do with permissions. I did yet another reboot and it seems to be working now. I made sure that my login had permissions for my temp folder and all TDA folders and areas in Windows/System32 and that seemed to work. Not sure what folder change made the issue stop.

I still hope to get to upgrade soon for the excel files being corrupted.

I spoke too early - this issue came back. So far today I’ve had three reports say that they were in use.

I’ve attached the Process Monitor results of the most recent Excel sharing issue.

Any help would be appreciated.

I like this software but not sure I can continue to use with all these problems.

Pete
Logfile_ExcelShaingIssue.zip (1000 KB)

I recognize the error of File in use. We did make a fix on this awhile back. We cannot make fixes to old releases. (Sorry). Can you please download which ever version you have, Base or Pro from the link below and try?

community-downloads.quest.com/.../ToadDataPoint_Base_3.5.0.2944.zip

community-downloads.quest.com/.../ToadDataPoint_pro_3.5.0.2944.zip

I have installed Excel 2013 and tested with the macro file attached and have no issues. Also, please try basic test using this macro file. I export data to Sheet one and fire the macros as shown below.

Here is one of the macro files I use to test with. Try the build I posted with this file first and see how it goes. If that works move back to your macro file and see how that goes.

Debbie
Macrodemotest.zip (127 KB)

Thanks Debbie - does the new file fix the mangled excel, the sharing issue or both? Either way, I will try, but want to set my own expectations.

I would hope both. We have done many changes since TDP 3.0.1

Recreated the export to my file and mangled again.

Then you need to send me the macro file, your automation script and show me in a screen shot what mangled means. Send to debbie.peabody@quest.com

Sent email - thanks for any help you can get me. This is really affecting my reporting and my users are getting upset. They expect the reports when they get in, but must wait for me to manually redo each one which takes hours. Also stopping me from getting new work done.

As discussed in email, for the File in use issue, try adding a pause activity right after Export wizard that uses the Macro file.

Peter,

We recently put a fix for a similar issue, I tried beta build 3.6.0.2875 and was able to successful export data to your xlsm file, could you please confirm it?

Here’s the download link www.toadworld.com/.../default.aspx

Thanks!