Toad World® Forums

VCS Provider is not logged in


#1

Toad for Oracle 12.1.1.1,

Team Coding with CVS.

I log in to team coding successfully because it says “…Info: Logged into CVS,…Info: Team Coding is running…” in the Output window. But, when I click on “Select VCS project…” the error, “VCS provider is not logged in” pops up. Other developers are prompted to log in again to CVS and when they do, the message, “getting modules from cvs server” displays and then the “Select Project” dialog box displays. Not for me. We’ve compared Toad Options | Source Control and they are identical.

What else should I check?


#2

Hello,

It sounds like either a working folder issue or an authentication issue.

The first thing I would try is to do a

In your Toad user files directory there will be a file called CVS.INI. You can find where your user files directory is located by looking in Options – General
– Application Data Directory. The User Files folder contains all the toad settings files. I would compare your file with another users file.

In the [GENERAL] section check the CVSRoot and UseEnvironment values. See if anything is different there. This may give you a hint.

There is also a section for each Login. You will not be able to copy these values because passwords are encrypted. However you should see the CVSRoot and working
folder. I would check that these are the same. Obviously , you do not need the same working folder as your colleagues but it might help to troubleshoot the issue if you replicated the working folder structure of a successful user.

Please let me know if this helps.

Stephen

From: daveoz [mailto:bounce-daveoz@toadworld.com]

Sent: Wednesday, March 19, 2014 3:34 PM

To: toadoracle@toadworld.com

Subject: [Toad for Oracle - Discussion Forum] VCS Provider is not logged in

VCS Provider is not logged in

Thread created by daveoz

Toad for Oracle 12.1.1.1,

Team Coding with CVS.

I log in to team coding successfully because it says “…Info: Logged into CVS,…Info: Team Coding is running…” in the Output window. But, when I click on “Select VCS project…” the error,
“VCS provider is not logged in” pops up. Other developers are prompted to log in again to CVS and when they do, the message, “getting modules from cvs server” displays and then the “Select Project” dialog box displays. Not for me. We’ve compared Toad Options
| Source Control and they are identical.

What else should I check?

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


#3

Thank you Stephen. It turns out there were multiple copies of Toad running on the desktop to different databases and when we closed them all out and used just the one it works fine.

Your answered helped greatly in overall understanding and we can see there are multiple entries in the cvs.ini and the different settings for each.

So, thank you!!


#4

Glad to help. Thank you for the update.

From: daveoz [mailto:bounce-daveoz@toadworld.com]

Sent: Wednesday, March 19, 2014 4:42 PM

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] VCS Provider is not logged in

RE: VCS Provider is not logged in

Reply by daveoz

Thank you Stephen. It turns out there were multiple copies of Toad running on the desktop to different databases and when we closed them all out and used just the one it works fine.

Your answered helped greatly in overall understanding and we can see there are multiple entries in the cvs.ini and the different settings for each.

So, thank you!!

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.