Toad World® Forums

Wrong formatting of list after paranthesis for parameter list


#1

Hi!

All my lists uses the shown default, the result after formatting does not correspond to the example for option 4:

2014-01-07 14 23 04.png

Kind regards

Torsten


#2

Furthermore the “more than” does not work too, the options in the following list should appear in one line as before:

2014-01-07 14 38 11.png


#3

Hi Torsten,

We tried setting all list options to default like those in your screenshot, but we could not reproduce the problem. Could you attach your formatter options file (C:\Program Files (x86)\Quest Software\SQL Navigator 7.0\FmtOptions.opt) or send it directly to me: vincent_liu@dell.com?

Thanks,

Vincent


#4

Hi!

This is an opt-File of an older release we deploy since several releases with success.

We do this, as this is the only way of deploying standard formatting options for all users at install time.

Maybe this file does not work with release 7.0.

With an xml file I cannot reproduce this issue. In release 7.0 I cannot see the save as opt file anymore to create a new opt file from my preferences?

Kind regards

[View:~/cfs-file.ashx/__key/communityserver-discussions-components-files/51/FmtOptions.zip:550:0]


#5

Hi Torsten,

Thanks for the opt file. We could reproduce the issue using your file. And yes, if you use XML format options there is no such issue. This is bug and luckily it has been fixed in latest QP5 formatter. I attached the new version and you can just download and unzip them to the path where SQLNav is installed. The new version is not fully tested regarding compatibilities with SQLNav v7.0. I suggest you to back up the old QP5.dll and FmtOptions.dll/exe before they are replaced.

7.0 formatter options can still be saved as opt file. You can select Any Files in the Save As dialog then manually specify opt ext to the filename.

Thanks,

Vincent
QP5v5.261.zip (5.23 MB)


#6

Thank you for the patch, there remains now only two issues. After cursor names are inluded 2 spaces instead of 1 or a tab (which are 2 spaces on my side) instead of a space:

cursor_and_fetch.png


#7

Hi Torsten,

The double space issue will be fixed in the next formatter drop.

Bug reference: QP-366.

Thanks for reporting!

Andre


#8

By the way, it would be a good idea to remove the entire [PlfOptionsOracle] section in your .opt file. Just remove all entries of it, should be 99 lines in total. This section is obsolete and not used at all if the [Qp5FormatterOptions] section is found. So just stick with [Qp5FormatterOptions], or use XML options - which are equivalent.


#9

Sorry if this is not the right forum but i’ve got a similar issue with current version of TOAD (12.1 with latest patch). I’ve set my parameterm declaration lists to be stacked only if more than one parameter. I case of only 1 paramter the formatter now inserts a blank before the first parameter. This was not the case at least until TOAD 11.6. Do you have an idea if this is a bug or where to get help for this TOAD issue?

toad.jpeg