Toad World® Forums

5.5.4: formatter review options not working


#1

I installed the 5.5.4 above 5.5.3 and the formatter inline advice do not compley with my code review options. I mean I deselct some of the reviews but the advice notice still appears!


#2

Hi Felipe,

do you mean that it worked as you wished in the 5.5.3, but the problem occured after upgrade? If this is a case we need to look why this happened, otherwise we probbaly cannot do much as Formatter Plus is a third party code included in SQL Nav and it hasn’t been upgraded for a long time. BTW, we are planning to replace it after 6.0 release (probably 6.1), with a new formatting tool, currently being developed in-house.

Rgds,
Andrew


#3

Yes it worked with 5.5.3!


#4

Will that be corrected due that it worked in the previous release?


#5

If it’s a regression problem, then yes, we will endeavor to fix it!!
We don’t want to move backwards in functionality.

  • Jaime -

#6

I found out the origin of the error.
I have also instaled the Quest Code tester and formatter was pointing to the opt from that system when I edited it.
Reinstalling SQL Navigator and changing the opt that formatter opened fix most of the reporting problem (I still have to enter 2 times in formatter for it to format the code was I want.


#7

Thanks for the update!!
That is some good investigating on your part… certainly makes our job easier

  • Jaime -

#8

We were able to reproduce this issue and found a bug. Indeed, Quest Code Tester, if installed, overwrites usual SQL Navigator’s PATH for formatter options (fmtOptions.opt) with its own path. Hence a problem for you. We take it aboard to to fix it, when we have new formatting tool available to us in one of the future releases.

Message was edited by: akot