Toad World® Forums

You do not have any Oracle homes installed

Hi

I'm actually using SQL Nav 7.3 (32bit) and I try to install 7.5 (64 bit). Oracle works perfectly with v 7.3, but I can't use v 7.5 due to this error : You do not have any Oracle homes installed.

  • Windows 10 Pro 64 bit
  • Oracle is in : c:\oracle\product\11.2.0\client_1\
  • Tnsnames.ora is in c:\oracle\product\11.2.0\client_1\network\admin\
  • Environment variable ORACLE_HOME : C:\oracle\product\11.2.0\client_1
  • Environment variable ORACLE_PATH : C:\oracle\product\11.2.0\client_1\bin
  • Environment variable TNS_ADMIN : C:\oracle\product\11.2.0\client_1\network\admin
  • Registry : Oracle is in HKEY_LOCAL_MACHINE/SOFTWARE/WOW6432Node/ORACLE

At the end of the installation, SQL Nav asked me if I want to reuse the parameters of the older versions, I answered YES. When I uninstall and reinstall the program doesn't ask me this question again. I tried the same installation on anther computer, responding NO to the question, same result.

Regards
Martin

Hi Martin, can you confirm the Oracle client you have is a 64-bit one? 64-bit SQL Navigator only works with 64-bit Oracle clients.
Thanks,
Vincent

1 Like

Hi Vincent

It's a 32 bit version, we'll install a 64bit version too.

I remember trying this with 7.3 and we didn't manage to make it working.

I'll let you know the result.

Regards
Martin

Hi Vincent

We manage to install Oracle in 64 bit and now it works.

Thanks
Martin