Toad World® Forums

Cannot update SQL Navigator. I need some help


#1

Hello everybody.
I have a problem installing SQL Nav 7.3 that my oraganizzation recently purchased both in 32 than 64 bit version.

First of all I uninstalled the old version of SQL Navigator then I proceed installing the new one.

My pc has installed win 7 64 bit, I have also installed oracle client 11.2.0.1.0 (but if necessary I could install a more recent version)
and I usuallly connect with a oracle 12.1 (12c) db server.
I dont remember well because now I’m not at work, but whether I try to install SQL Nav 7.3 both 32-bit than 64-bit version, at the end of installation,
when I try to connect to the server I get errors such as “missing OCI.dll” or an error that the program can not locate the tnsnamer.ora file.
How should I proceed?
First question: I have to try back installing the 32 bit version or the 64 bit version or it would be the same?
Which version can be considered more stable?
How can I overcome the error messages mentioned above?

Thank in advance.
Roberto


#2

looks like you did not installed Oracle client on your machine… the Oracle client and SQL/Nav must match 32x or 64x both; if you installed client 32x, you must install SQL/Nav 32x.


#3

I’ve just installed an oracle 32 bit oracle client version 11g…

This morning I tryed ti deinstall and reinstall the client again, but I get this error.

The previous verison of Sql Nav 7.0.0 is still working, but the new SQL Nav 7.3 32 bit doesn’t work.

I have not idea how to proceed.

Please help me.

Immagine_1.png

Immagine_2.png

Immagine_3.png


#4

I have not solved my problem yet. (Cannot find any oracle client)

I installed oracle administrator client 12.1 and SQL Developer works fine.

Anybody can help me, please?


#5

Only formatting the main disk of PC I solved my problem :frowning:

Two days after this brutal procedure I thought to load the SQL Nav preferences file (.pref) I saved before in a separate drive. (the .pref file came from a previous but working version of SQL Nav)

Try guessing what happened…

I got the same error: “Cannot find any oracle client”.

After various and original curses faced to the sky, I tried to restore the SQL Nav prefs to its default values pushing the dedicated button in View --> Preferences --> Reset

Fortunately it worked and I regaing a full functionality of the program.

Now I think I understand what happened during the installation process.

After the installation, SQL Nav loaded some file(s) from my user application data folder in C: drive even if I had correctly uninstalled the previous versions of program.

The uninstallation procedure did not properly delete these files, I guess.

So, what I can suggest whom have a problem like mine is to try to reset the program preferences before considering drastic methods…

I hope it is helpful to others.

Cheers


#6

Hi robbi73

This is the clue that fixed the “Cannot find any oracle clients” error at my workplace.

We were trying to update verion 6.7 installations to 7.3.

After getting that error, I asked the developers to reset their preference files and it worked right away.

They had been importing their preferences from their 6.7 versions. I guess they are incompatible?

Thank you :slight_smile: