Toad World® Forums

Access violation 041A3E6C, TOAD shuts down

I have been getting an access violation error ending in 041A3E6C times a day now. After clicking "OK", TOAD shuts down. It seems to occur when I am working on something and not keeping the connection up. Thoughts?

Those memory addresses in error messages mean nothing to us.

We really need the call stack.

Hopefully you are seeing an error message similar to this:

If so, click where it says "Click here".

Then you'll see something like this:

Check the "Copy to Clipboard" box, then click OK, then paste the contents of your clipboard here in the forum.

Also, please let us know which Toad version you are on.


The error box looks like this, so I don't have anything to click on:

TOAD version

Oh, ok.

Do you have any more info on how it happens?

I know you said connection is likely lost. What did you do or click immediately before the error?

I have been working on lost-connection-type problems in the beta, you might want to give that a try (keeping your current version installed also). You can get beta version here: Toad for Oracle 15.0 Beta

I don't know if there is anything special I do to get the error or not, as it doesn't seem to occur every time a reconnection occurs and I do something. But, I believe at least the last two times it was when the connection was lost and I clicked a table in the Tables tab with while the data tab was open. But, maybe I clicked on the Data tab from another one, too. I am relatively confident it was one of those two.

Thanks for your help. I will try the Beta.

Thanks, I can try that. Had you been editing the data in the data tab or just looking at it?

Just looking. The connection had timed out because I was doing something else, in a meeting, staring into space ...

No, Not getting any error, just a complete BAM! shut down.

As stated above... Not error message just a hard shut down.

are you looking at a table with any kind of LOBs?

Also, what causes your timeouts? I just tested with a database profile timeout, that worked OK for me. But a network glitch or a forced timeout from a server might have different results

A few tables have CLOBs. I don't think I was selecting that one, but that might be a possibility. I wish I remembered.

Our Core DB team manages the databases on a cluster, and I don't know the details of how they manage them. I am working on a 12c database in our Dev lane. I haven't noticed it on other lanes ... but I'm not working in other lanes right now. If I get a chance, I will try test or two on TOAD 14 while I work in 15.

1 Like

I just tried this with 64 bit Toad 14 and didn't get a shutdown.

I tried:

  • db profile time out
  • azure server network idle timeout
  • connection lost by db shutdown

If you can find out any specifics on your timeout mechanism from your core DB team, I will set it up here if I can and try again. Toad 15 beta may give a more helpful error message.

Haven't been able to get the exact error in either v14 or v15 the last two days. But, I have things lock. This error, twice, leaves me stuck, and I have to use Task Manager to kill TOAD. Maybe helpful?

This one let me use the "click here" and get a lengthy report, but I guess new users can't upload. If interested, let me know how best to get it to you.

Regarding the locks... if they occurred after selecting text and replacing the selection by pressing a key then that is fixed in next beta to be released.

TOADError.txt (95.6 KB)

Uploaded the info. Hope it helps!