Toad World® Forums

Toad for Oracle -- memory access violation


#1

Toad for Oracle is giving me a memory access violation EVERY time I start it up.

This started (for me) in Toad for Oracle 12.7.0.121, freeware edition.

It happens after clicking the “Connect” button in the session/connection chooser.
(Actually, it happens EVERY time it starts to make a new connection.)

If you click on the link for the additional information, it provides a lot of it but it’s probably only useful to a developer on the Toad Team.

Here’s at least the exception identity:

Exception:

2.1 Date : Fri, 28 Aug 2015 13:35:41 -0400
2.2 Address : 072EA6C8
2.3 Module Name: Toad.exe - (Toad™ for Oracle®)
2.5 Type : EAccessViolation
2.6 Message : Access violation at address 072EA6C8 in module ‘Toad.exe’. Read of address 00000004
2.7 ID : 5DFB0000
2.8 Count : 1
2.11 Sent : 0

The two addresses and the ID are always the same.

The assembler window also has a couple of interesting comments:

; ToadRegistration.TToadKey.GetKeyDesc (Line=0 - Offset=13)
— disassembly stuff elided here.

; ToadRegistration.TToadKey.GetKeyType (Line=0 - Offset=0)
; --------------------------------------------------------
072EA6C8 83780400 CMP DWORD PTR [EAX+4], 0 ; <-- EXCEPTION
072EA6CC 7403 JZ +3 ; ($072EA6D1) ToadRegistration.TToadKey.GetKeyType (Line=0)

What is REALLY odd is that every time I do a connection, I also get the “Commercial Feature” warning dialog! (I doubt it means an ordinary database connection is a commercial feature, so this may be a clue that it’s trying to do something that the freeware edition shouldn’t.

Here’s hoping that some of the developers of Toad are readers of this forum!

What’s also odd is that after the violation, it seems to connect and operate normally. Which leads me to wonder what happened to the thread that crashed? Did it clean up after the exception?


#2

It looks cut off above, so here’s the addresses again:

Access violation at address 072EA6C8 in module ‘Toad.exe’. Read of address 00000004.


#3

Here’s hoping that some of the developers of Toad are readers of this forum!

The entire dev team is here. Attach the log file (Toad.el) that is generated.


#4

Outstanding! Thanks! (Log file forthcoming…)


#5

Hm… where does it write the log file? I’m having trouble finding it.


#6

Go to options > general. Click “open folder” under your application data directory. You should see Toad.el

From: Forbin1 [mailto:bounce-Forbin1@toadworld.com]

Sent: Friday, August 28, 2015 2:15 PM

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] Toad for Oracle – memory access violation

RE: Toad for Oracle – memory access violation

Reply by Forbin1

Hm… where does it write the log file? I’m having trouble finding it.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


#7

[Deleted – didn’t mean to send to the entire forum.]


#8

I’m having some trouble reproducing the error you’re seeing, so let me ask a few questions to start off:

  1. Have you tried resetting your user files using the “Utilties -> Copy User Settings -> Reset to a clean set of user files from the base installation” as shown here?

6523.Capture1.jpeg

  1. Do you have any files called “ProductLicenses.xml” located in either of the following folders:

a) C:\Users<your username>\AppData\Local<Long GUID starting wiith “{08439”>\

b) C:\ProgramData<Long GUID starting with “{08439”>\

If so, can you rename those files and try opening Toad again?

  1. Do you have Toad set up to automatically open specific windows upon making a new connection?

-John


#9

Just checked. No such file “ProductLicenses.xml”, nor even the directories with the GUID names.

I’m checking the TOAD config dialog(s) to see if I have any windows set to automatically open. I don’t think I’ve set it up that way, though. Anything you’d like me to specifically check? (I’m just running down the tree, using the Search facility first.)

BTW, did you guys receive the log file I sent? I tried sending directly as an attachment via e-mail.

–aaaugh, I can’t sign this “john.b” because we’re both John B. :slight_smile:


#10

I did find the following 3 files in the directory where Toad is installed:

FullToad.lic

readonly.lic

toad.lic


#11

In the Windows section of the tree, the following had “Auto Open” checked:

  • Editor

  • Schema Browser

  • Schema Browser Legend.

Additionally, the combo box for “Auto-open bring to front:” was set on “Editor”.

I’ll try clearing those one at a time and see if it helps.

–JTB


#12

Interesting!

  1. Clearing the Legend (only) got rid of the memory access violation, but kept the Commercial Feature warning.

  2. Clearing the Schema Browser (only) got rid of the Commercial Feature warning, but kept the memory access violation.

  3. Clearing auto-open from BOTH “Schema Browser” and “Schema Browser Legend” caused the problem to NOT occur, as might be expected from (1) and (2).

  4. Clearing the Editor didn’t help.


#13

Forbin1, the freeware was updated a few days ago. Please pull the latest version (12.7.1) and let me know if the Access Violations go away. I believe they will.


#14

Oh, and as for the Commercial Feature warning message -

You are supposed to be seeing that when the Schema Browser opens, but the message is wrong. It should say:

Certain object types are not allowed.

Multiselect is disabled.

History is disabled.

Jump navigation is disabled.

Tab customization is disabled.

Partition management is disabled.

Various other features.

That will be fixed in the next freeware.


#15

Wonderful!

Thank you, I will pull the new download and install it this afternoon. I’ll post feedback here regarding what I find.

regards,

– john.b.


#16

Update Done --> new Crash Done

Version : 7.0.7.1

Date : Tue, 1 Sep 2015 16:28:35 +0200

OS : Microsoft Windows 7 (64 bit)

RAD : BDS 9.0

Dump : $48 $8B $51 $90 $48 $89 $C1 $E8 $A9 $A8 $00 $00 $48 $89 $D8 $48 $83 $C4 $20 $5B $C3 $55 $48 $83 $EC $60 $48 $8B $EC $48 $89 $4D

Section : ExceptionHandlerHook

Descr :

Address : $000000000419C3FB - [0000000004190000] Toad.exe - System - TObject - ClassName - 12951[11]

Module : Toad.exe

Exception : EAccessViolation

Message : Access violation at address 000000000419C3FB in module ‘Toad.exe’. Read of address FFFFFFFFFFFFFFFF

Call Stack : 00 $000000000419C3FB - [0000000004190000] Toad.exe - System - TObject - ClassName - 12951[11]

01 $000000000438B7B9 - [0000000004190000] Toad.exe - ECallStack - TEurekaBaseStackList - Build - 2067[169]

02 $00000000045FDA58 - [0000000004190000] Toad.exe - ExceptionLog7 - - GetCallStackDump - 487[184]

03 $00000000045FE9C4 - [0000000004190000] Toad.exe - ExceptionLog7 - - FullInternalErrorReport - 709[2788]

04 $00000000042FFED5 - [0000000004190000] Toad.exe - EBase - - InternalErrorSet - 823[805]

05 $00000000045F8A79 - [0000000004190000] Toad.exe - EInject - - ExceptionHandlerHook - 513[153]


#17

Unfortunately, that call stack isn’t very helpful. Some of them are like that.

I just pulled the lastest freeware and tried it - no problems here. I tried connecting to Oracle version 12.1.0.1 and 12.1.0.2 (prior version had problems with 12.1.0.2). It may not matter, but what version of Oracle are you trying to connect to?

If you want to zip up and send me (john.dorlon@quest.com) your user files folder, I’ll take a look, or you could try resetting them. You can do either one of those from the main menu, Utilities -> Copy User Settings.


#18

Sorry for the extreme delay; got pulled off onto other, higher priorities, and only now able to return to this!

I uninstalled 12.7.0.121, and installed the latest build, 12.7.1.11.

Memory access violations GONE.

Thanks for such a rapid fix!

–john.b.


#19

I have 12.7.1.11 and I get the same EAccessViolation error all the time when switching between Server tabs. It’s really frustrating when it crashes all my work.