Toad World® Forums

Access violation at address 0094A3A0 in module 'toad.exe'. read of address 000000008


#1

Dear friends,

I have recently upgraded my oracle database from oracle 10g to oracle 12c.

I was using Toad version 9, 9.7 and 10.6 for connecting to oracle 10g.

After i upgraded to oracle 12c, toad version 10.6 only was working. On and off i get this error.

is this a compatible issue? what is the compatible version of toad for oracle 12c.

If it's not a compatibility issue can anyone suggest solutions to this issue.

thanks in advance


#2

Toad 10.6 is almost 10 years old and your error message is vague. I have no idea why you got this error. The address is not a code that we can easily decipher.

I suggest Utilities -> Copy User Settings -> Reset to a clean set of user files.

If that doesn't solve the problem, I suggest upgrading to most recent version of Toad. If that is not an option, at least let us know how to reproduce the problem so maybe we can help.


#3

Thanks a lot sir for your response.

This error is not occurring regularly, but it does happens atleast once in two days. If i close the error message and connect the toad again then it works fine.

You have asked me to tell how to reproduce the problem. I am not able to understand this . Could you please let me know what other details do you need from me.

I have started using toad 10.6 only 10 days back after we upgraded our oracle 10g to oracle 12c.

Could you please suggest what is the toad version which is compatible for oracle 12c.

May be there is a compatibility issue, i don't know


#4

You have asked me to tell how to reproduce the problem. I am not able to understand this

I mean, can you give me some steps that i can follow in my copy of Toad so that I can get the error message too.

Could you please suggest what is the toad version which is compatible for oracle 12c.

This may or may not be a compatibility problem. Toad 10.6 was never tested with Oracle 12 because Oracle 12 came out so much later than Toad 10.6.

If you want a version of Toad that was certified with Oracle 12.1, you should get at least Toad version 12.1 (the matching version number is a coincidence).
If you want a version of Toad that was certified with Oracle 12.2, you should get at least Toad version 12.11

But as long as you are updating Toad, it would be best to update to the most recent version, which is 13.1.