Toad World® Forums

Access violation at address 041999E5 in module 'Toad.exe'. Read of address 1DAB6000.

The file attached was blocked by forum moderation, it will come as soon as they will accept the message. I posted the attach 5 seconds after the main post - sorry for this.

Earlier you mentioned that it appeared to be related to the real-time syntax check. You can disable that by unchecking the “Check syntax as you type” checkbox in Options on the Editor|Code Assist page. I don’t see how that could cause this, but if you want to disable to test have at it because the latest call stack has me stumped.

The earlier call stacks indicate failure with a string pointer when Toad receives notifications from the edit component. Those made sense because Toad was not copying the string locally for use, but instead counting on the memory address of the string to remain constant for some time. Those have been corrected and now we see a shift in your AV from the notification method to the WndProc() where we are no longer working with a string pointer provided by the edit control. However, the AV is when trying to calculate a string length suggesting a bad string pointer as before. I’m just guessing, but I wonder if the problem is more pronounced or specific to Windows 2003. I see that you’re using this old version on VMWare ESX. I use Win7 on VMWare Workstation and have had no issues with VMWare. I’ll grab a Win2003 VM and test here as well.

Is there anything specific that you can think of that you’re doing when this happens? One thing that comes to mind is Auto Replace. Do you make use of this feature? When you type “form” (without quotes) Toad will automatically convert it to “from.” Does this work OK for you?

Michael

Ok I made some tries. Actually running with ‘Check syntax as you type’ off and Auto Replace is on and working (but I’m typing with caps lock and auto replace is case sensitive so it don’t change what I type).

The result is in the toad.el attached.

I got a lot of errors using backspace to delete end of query and then using ctrl-z to remove the backspace action and restore the code. I tried a lot.

The weird thing is that switching off toad and restarting again, with the same code in the editor and trying to do the same action (backspace from the end of query) nothing happens and all seems to work.

I’m still trying to have something that produce the error in a replicable way.

Thanks for all

Steven
Toad.55.el.txt (1.11 MB)

I tried Windows Server 2003 with latest beta and wasn’t able to reproduce after a few minutes. I tried a lot of typing, backspace, select and delete, pasting, and throwing in a bunch of Undo in there. If you come up with something pass it along. I’d also try restarting your machine. It’s been up for 34+ days according to a recent error log.

I’m trying to restart the server (btw 34+ days for a server is not so much: a server box should be never restarted. I have servers running for years) and see what happens.

I really hope to find an operation sequence or something else to reproduce the problem.

I’ll enable syntax checking again to see if is involved in the problem. Seems that it comes up when I edit a line and the text in the editor at cursor position can be an alias or table name. It hangs for maybe half second and then gives access violation. The behaviour is similar to the little ‘pause’ before show the available fields for a table or an alias (when typing the dot after a table/alias name).

Still experimenting…

Ok, server restarted, opened toad 12.9.0.55 (still with syntax check disabled), pasted a script in the editor, go to the end of the script and pressed the backspace. Keeping pressed the backspace, with keyboard repeat, and deleting chars from the end, after 6 lines removed the AV comes up.

After the first error, I pressed Ctrl-Z to have back the character just deleted and here comes the second AV. clicking on theOK button on the AV dialog another AV comes up.

toad.el attached (toad.55new.el.tx)

P.S. I’ve closed toad and reopened again, do the same sequence (open a view from schema brouser, open the script tab, copy the select portion of the view in the clipboard, past in the SQL editor window, keep pressed the backspace) and the AV comes up again. Not in the same place, I deleted 15/20 lines then it comes. And Pressing Ctrl-Z gives the 2 other AV.

I cant attach a second toad.el but I have it if you need it.

I hope this help!
Toad.55.new.el.txt (404 KB)

a server box should be never restarted

Yesterday I was looking for any info on Win 2003 since it’s so old to see if there were any known problems that would suggest restarts and a monthly restart of any server, timed with patches or upgrades, was often recommended. Additional restarts as needed for software installs or to clean up applications having resource leaks was also mentioned. I’m not a server admin so I’m just regurgitating what I found in several forums and the info wasn’t specific to Win 2003. Many were in the never restart camp as well.

Just in case Toad or some other process is wreaking havoc it’s best to start from a clean slate. We have many users and I’ve seen a report of an AV here and there in the new edit control, but nothing coming close to approaching the frequency that you’re seeing them. I think there’s something about your environment causing or surfacing a problem, but that’s just a guess.

Thanks,

Michael

Please remove moderation for double posting: I posted results of test done on a clean environment and they are in moderation queue. In this way is impossible to give feedback. I tried to contact you, Michal, sending a PM but had no reply.

Regards,

Steven

PS try to google “how often do windows server need to be restarted” they says ‘when you install patches’. I have a stable system that I must use because some software is certified on that platform. In previous version of toad (12.1 for example) I never had that problem.

Yeah I’m not arguing the restart, I just suggested it because I saw conflicting info on forums and monthly for good measure, patches, software updates and when an application is having problems were all commonly suggested triggers. There were just as many suggesting don’t bother with it. Something is definitely wrong with Toad for you so I was curious if a restart would clear things up. From your latest post I see that it did not.

I’ve contacted the admin for Toad World to see about the moderation. I assume some changes may have been made recently due to increased spamming.

The post with my attempt to reproduce the problem was finally added to thread. Please go back 4 posts to read it (is the one with toad.55.new.el attached)

Thanks, I looked at the AV last week. The latest ones are all consistently failing in the control’s WndProc.

Keeping pressed the backspace, with keyboard repeat, and deleting chars from the end, after 6 lines removed the AV comes up.

Steven, I can reproduce in Win 2003 in this way. I’ll need to try and setup some way to debug this. Unfortunately the problem does not occur on Win7 which is my development environment.

Finally!

I’m very happy that the AV can be reproduced! In this way I hope that will be simpler to fix it.

Good job!

I assume that running Toad on a development box with a newer version of Windows and not directly on your old server is out of the question. Setting up our full development environment on Win 2003 is not going to happen so I’ll poke around with what I have seeing what can come of it. Win 2003 is so old it is probably soon on its way out of the officially supported list of OSes.

I think that part of the issue is the use of a VERY old operating system. Microsoft quit supporting it almost a year ago (even with their extended end of life). As tools move forward, there are situations where the older operating systems just are no longer compatible. Hopefully, this isn’t the case but you never can tell with an OS that’s well over a decade old.

I got the same problem with toad 12.8 and windows 2003 was one of the supported o.s.

I know that 2003 is not supported anymore but I work for the public administration and we have tons of certified platforms working on 2003 server. Of course we will migrate, but certainly not now.

I think that there is a problem somewhere and is not visible on other platform, while on my ‘old’ system is easier to get it.

This is my 2 cents

I would counter that you didn’t have issues with a prior version of Toad but Toad as an application has to continue to move forward and there are going to be wider and wider gaps between the versions of Windows that we can simply no longer support. A great example is Office 2010 was the last one officially supported for Windows 2003. At some point, new programs can no longer support older OSs due to the incompatibility of the Windows versions.

We always strive to support older versions but at some point, the cost of doing so simply becomes too high…especially when Microsoft themselves no longer provide any support.

any news?

I have nothing. I tried for the better part of 2 days last week and got nowhere. Disabling the notifications that the edit control sends to Toad eliminates it, but that’s not a solution. It’s just an observation I made while debugging. If I enable the notifications, but eliminate all of the Toad code that fires in response the AVs still persist. There is something that just doesn’t play well with antique OSes. Windows Server 2003 and XP are no longer supported going forward, sorry. You’re already using ESX so if you can setup a development VM instead of using the server directly you can install a newer OS and Toad on it and still connect to your server.