Toad World® Forums

Add watch icon and menu disabled.

hi… I’m new to this community. I am trying to debug a proc in a package. I have compiled with debug. But when I try to add in break points or watches, nothing happens with the break point and the Add Watch icon is disabled. I am logged in as sys so I do have the debug connect session priv, dbms_debug is installed on this oracle instance… I would really like to figure out what the issue is. Any help would be great!

it is toad for oracle

thank you!

It’s not a read-only connection, is it?

hi, no I’m in as sys

There’s a setting on the login window to make a connection read-only. It even works for SYS. If that’s not it - it sounds like you have all the bases covered. Maybe if you post a screen shot, that will help me see what’s going on. The dev who “owns” the Editor and Debugger is out, so you’re stuck with me.

Just logging in as sys does not guarantee the privs necessary. See the blog here:…/common-toad-security-connection-mistakes

Double check your grants in the Schema Browser. Better yet, create a debug user and grant the privs necessary.

John: here’s are screen shot:

John I tried to post screen shot, but it does not work. I checked the connection, but the read only is NOT checked… thank you !

Gregory: I will take a look at that link and see if I’ve missed something there. Thanks!

hi thanks for all the help.

Gregory, we are working on the logins :slight_smile: and do realize that overuse of the sys accounts is bad, but have to work on that.

I did find the issue. In toad options, one must make sure that under Debugger, DBMS radio button is checked, then all the options in debug modjavascript:void(0);e start to javascript:void(0);work!