Toad World® Forums

Adding CR to txt files when ftp'ing from unix to Windows/dos


#1

I am using TOAD for Oracle R11.6. I have txt set up in my FTP ASCII Extensions. When I ftp a *.txt file from linux to Windows I do not get the CR added to each line.

There are radio buttons at the bottom of the ftp window, ascii, binary and default, but they are grayed out. Default is on.

I am really embarassed because I have been sending files for months and the guy on the other end finally told me he couldn’t use them in his program because they didn’t have the CR. I never checked. I just thought they would be there. But they are not.

ftp.jpeg


#2

Is this a Toad question? If you are asking how to add CR when FTPing from linux to Windows perhaps your FTP client has an option. I use FileZilla and do not see one. You can also change your newlines to CRLF prior to saving if the files are needed on Windows.
I use Geany text editor and it has options to convert newlines.

On 11/21/2013 08:31 AM, gtaylor wrote:

Adding CR to txt files when ftp’ing from unix to Windows/dos

Thread created by gtaylor
I am using TOAD for Oracle R11.6. I have txt set up in my FTP ASCII Extensions. When I ftp a *.txt file from linux to Windows I do not get the CR added to each line.

There are radio buttons at the bottom of the ftp window, ascii, binary and default, but they are grayed out. Default is on.

I am really embarassed because I have been sending files for months and the guy on the other end finally told me he couldn’t use them in his program because they didn’t have the CR. I never checked. I just thought they would be there. But they are not.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


#3

It is a TOAD question. I am using Utilities > FTP from the menu bar. I have not set up any ftp clients so I am assuming that one comes with TOAD. The fact that I have setups in TOAD options for FTP ASCII Extensions (under Network Utilities) and the radio buttons on the bottom of the ftp window indicate that TOAD provides this functionality.

I am now using unix2dos to put the CR’s on the lines before FTPing, so I have a solution outside of TOAD. I would like to know if there is some way to get this to work in TOAD since it looks like the setups are there.


#4

There is no way to do this with Toad’s FTP tool. Are your filenames static? If so you could use the Automation Designer to run unix2dos on your files and then FTP. See the Automation Designer on the Utilities menu. You can create a new app in there and add
a Shell Execute action from the Utilities tab and set it up to execute unix2dos and then add an FTP action, also on the Utilities tab, to send it along. This app can be executed easily at any time and also via command line.

On 11/21/2013 11:51 AM, gtaylor wrote:

RE: Adding CR to txt files when ftp’ing from unix to Windows/dos

Reply by gtaylor
It is a TOAD question. I am using Utilities > FTP from the menu bar. I have not set up any ftp clients so I am assuming that one comes with TOAD. The fact that I have setups in TOAD options for FTP ASCII Extensions (under Network Utilities) and the radio
buttons on the bottom of the ftp window indicate that TOAD provides this functionality.

I am now using unix2dos to put the CR’s on the lines before FTPing, so I have a solution outside of TOAD. I would like to know if there is some way to get this to work in TOAD since it looks like the setups are there.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


#5

Another thought…have you tried removing txt from the ASCII extensions and tried transferring in binary mode?


#6

I know that if I transfer in binary mode the CR will not be added.

I’ve thought about taking all of the extensions out and seeing if the buttons at the bottom of the ftp page become accessible. Then I could check ‘ASCII’ instead of ‘Default’ and see what happens. I’ve gotten swamped with priority tasks so I’ll get to this when I can and let you know how it goes.

Thanks.


#7

I don’t believe that any combination of transfer options is going to modify your text to convert between newline formats. I think that you’re going to need to work with your files in such a way that they are formatted as required for the target application.

On 11/22/2013 04:07 PM, gtaylor wrote:

RE: Adding CR to txt files when ftp’ing from unix to Windows/dos

Reply by gtaylor
I know that if I transfer in binary mode the CR will not be added.

I’ve thought about taking all of the extensions out and seeing if the buttons at the bottom of the ftp page become accessible. Then I could check ‘ASCII’ instead of ‘Default’ and see what happens. I’ve gotten swamped with priority tasks so I’ll get to this
when I can and let you know how it goes.

Thanks.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.