Toad World® Forums

After Connection is Lost, Toad crashed

Below problem happens in 11.5 and up versions. (Never tested Beta)

You’re working on one DB and there is latency/inactivity control on session. When this time is passed you have to re-connect. But after connection is lost and you are on query on that db (assuming editor is still open). Toad behaves wrongly, rendering lost, icons changed etc.

The annoying part is this happens a lot and workaround for this before running any query if you hit “Test Connection (Reconnect)” then Toad behaves normally.

But if forget (generally you do) then execute any query (or open any windows that queries DB) than, it gives error to Reconnect then we click reconnect then voila. You cannot end session, close tab, close window even you cannot close Toad. Menus are dissappear some rendering problems occurs. Result we have kill Toad.

Same problem doesn’t happen before v11.5.

Expected results: After any communication channel problem ( DB crash, or session timeout, DB shutdown whatever) when toad gives error about to reconnect session. Then it should try to reconnect session.

Same behavior when we click Test Connection (Reconnect) on Session Menu.

Is this a bug?

for the post “http://www.toadworld.com/products/toad-for-oracle/f/10/t/19921.aspx

You cannot end session, close tab, close window even you cannot close Toad.

Is this in Toad 12.1 as well? This has come up before and there are a few conditions that would prevent you from closing tab, editor, connection, and Toad. If the Editor thinks you are debugging or executing a statement in particular is the main cause. I tried
to handle those conditions better to be sure that they are unset appropriately to prevent this, but may need to revisit. If you are on Toad 12.0 or earlier try 12.1 as some changes did go in for that release.

Michael

On 10/07/2013 03:26 AM, lostxp wrote:

After Connection is Lost, Toad crashed

Thread created by lostxp
Below problem happens in 11.5 and up versions. (Never tested Beta)

You’re working on one DB and there is latency/inactivity control on session. When this time is passed you have to re-connect. But after connection is lost and you are on query on that db (assuming editor is still open). Toad behaves wrongly, rendering lost,
icons changed etc.

The annoying part is this happens a lot and workaround for this before running any query if you hit “Test Connection (Reconnect)” then Toad behaves normally.

But if forget (generally you do) then execute any query (or open any windows that queries DB) than, it gives error to Reconnect then we click reconnect then voila. You cannot end session, close tab, close window even you cannot close Toad. Menus are dissappear
some rendering problems occurs. Result we have kill Toad.

Same problem doesn’t happen before v11.5.

Expected results: After any communication channel problem ( DB crash, or session timeout, DB shutdown whatever) when toad gives error about to reconnect session. Then it should try to reconnect session.

Same behavior when we click Test Connection (Reconnect) on Session Menu.

Is this a bug?

for the post “http://www.toadworld.com/products/toad-for-oracle/f/10/t/19921.aspx

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

I just install new version (12.1.0.22). It doesn’t happen in this version. No popup is comming to reconnect, no rendering problems and queries work (i think it automatically connects again)

But another things happen even there is no running queries on any editor i cannot disconnect from DB so again i have to kill Toad.exe.