Toad World® Forums

Alter Table

I created a table, and realized I crossed two tables. Oops. So, I went to Alter Table, to straighten it out. I deleted several columns, renamed some others, changed column and table descriptions, and altered foreign keys.

I then looked at the SQL script. All it had were the column renames. Lots of work lost!

I ran the nearly worthless script, which indeed just renamed three columns, and then tried Alter Table again. I deleted the unwanted columns and foreign keys. I then checked the SQL script. NO CHANGES DETECTED! WHAT?!?!?!

I then disconnected from the DB, reconnected, and tried again. Still NO CHANGES DETECTED! So, I guess it is off to SSMS. [:@]

This is v6.0.

OK. This apparently was related to the problem I had with the schema compare. My login’s default DB was set to a DB that no longer existed.

Wierd things happen when your default DB becomes invalid.

Hi,

you are right. That is b/c of availability default db for your login. That will be fixed within CR110308 that I just created regarding your post for the Schema Compare.