Toad World® Forums

Auto-Replace no longer accepts special characters


#1

I use auto-replace quite a lot as do some of my colleagues - we’re lazy typists! Anyway, I have the start of many of my most common queries as auto-replace options for instance s*msi is replaced (up to and including 12.6) with Select * From Mtl_System_Items_Vl Where. But now it doesn’t seem to like the asterisk and doesn’t expand to anything. I know the editor has been changed but is this feature something that can be re-instated?

Thanks,

Mark.


#2

I’ll take a look at this today.

From: markagardner [mailto:bounce-markagardner@toadworld.com]

Sent: Thursday, June 25, 2015 9:22 AM

To: toadoraclebeta@toadworld.com

Subject: [Toad for Oracle - Beta Discussion Forum] Auto-Replace no longer accepts special characters

Auto-Replace no longer accepts special characters

Thread created by markagardner

I use auto-replace quite a lot as do some of my colleagues - we’re lazy typists! Anyway, I have the start of many of my most common queries as auto-replace options for instance
s*msi is replaced (up to and including 12.6) with
Select * From Mtl_System_Items_Vl Where . But now it doesn’t seem to like the asterisk and doesn’t expand to anything. I know the editor has been changed but is this feature something that can be
re-instated?

Thanks,

Mark.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - Beta
notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag
this post as spam/abuse.


#3

It’s working fine for me in 12.8.0.3.

I too am an “efficient” typist. I use s* for 'select * from '. It’s working fine for me.

From: Michael Staszewski [mailto:bounce-mstaszew@toadworld.com]

Sent: Thursday, June 25, 2015 8:24 AM

To: toadoraclebeta@toadworld.com

Subject: RE: [Toad for Oracle - Beta Discussion Forum] Auto-Replace no longer accepts special characters

RE:
Auto-Replace no longer accepts special characters

Reply by Michael Staszewski

I’ll take a look at this today.

From: markagardner [mailto:bounce-markagardner@toadworld.com]

Sent: Thursday, June 25, 2015 9:22 AM

To: toadoraclebeta@toadworld.com

Subject: [Toad for Oracle - Beta Discussion Forum] Auto-Replace no longer accepts special characters

Auto-Replace
no longer accepts special characters

Thread created by markagardner

I use auto-replace quite a lot as do some of my colleagues - we’re lazy typists! Anyway, I have the start of many of my most common queries as auto-replace options for instance
s*msi is replaced (up to and including 12.6) with
Select * From Mtl_System_Items_Vl Where . But now it doesn’t seem to like the asterisk and doesn’t expand to anything. I know the editor has been changed but is this feature something that can be
re-instated?

Thanks,

Mark.

To reply, please reply-all to this email.

Stop
receiving emails
on this subject.

Or
Unsubscribe from Toad for Oracle - Beta
notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag
this post as spam/abuse.

To reply, please reply-all to this email.

Stop
receiving emails
on this subject.

Or
Unsubscribe from Toad for Oracle - Beta
notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag
this post as spam/abuse.


#4

I’ve just noticed something else too which I think may be related. Rowid, when typed on its own is shown in red but now, if I use a table alias and refer to Rowid using that (i.e. a.Rowid) it is unchanged. It looks like special characters are being treated differently so where it previously knew the dot was a separator, it now thinks it’s part of the string.


#5

Yes crjohnso, I’ve just tried it and it works so long as the asterisk doesn’t have anything after it. If you set one up as s*d for Select * from Dual and it won’t work.


#6

Fixed for next beta.

From: markagardner [mailto:bounce-markagardner@toadworld.com]

Sent: Thursday, June 25, 2015 9:50 AM

To: toadoraclebeta@toadworld.com

Subject: RE: [Toad for Oracle - Beta Discussion Forum] Auto-Replace no longer accepts special characters

RE: Auto-Replace no longer accepts special characters

Reply by markagardner

Yes, I’ve just tried it and it works so long as the asterisk doesn’t have anything after it. If you set one up as s*d for Select * from Dual and it won’t work.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - Beta
notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag
this post as spam/abuse.


#7

This is an odd one. A period is part of an identifier and it’s important that it remains so when lexing. Changing this behavior will have larger impact on many
other features and we’d be hacking around it for a long time. Also, rowid is highlighted using the Datatypes style and it’s stored internally in our list of datatypes. I’m not sure why that is, but it’s been so for a long time. Being a pseudocolumn I’d argue
that it has no place being lumped in with datatypes and highlighted in that way. There’s really not much to be done here.

Michael

From: markagardner [mailto:bounce-markagardner@toadworld.com]

Sent: Thursday, June 25, 2015 9:46 AM

To: toadoraclebeta@toadworld.com

Subject: RE: [Toad for Oracle - Beta Discussion Forum] Auto-Replace no longer accepts special characters

RE: Auto-Replace no longer accepts special characters

Reply by markagardner

I’ve just noticed something else too which I think may be related. Rowid, when typed on its own is shown in red but now, if I use a table alias and refer to Rowid using that (i.e. a.Rowid) it
is unchanged. It looks like special characters are being treated differently so where it previously knew the dot was a separator, it now thinks it’s part of the string.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - Beta
notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag
this post as spam/abuse.


#8

I’m not sure I understand what you mean when you say “A period is part of an identifier” - surely it’s a separator - it separates the alias from the column name. The behaviour of the old editor (or so it seemed) was to treat a.Rowid as three things: the alias (a), the separator (.) and the column name (Rowid). The new editor (or so it seems) is treating it as one string and therefore not recognising the word rowid. Anyway, it doesn’t stop the code working - the DB still recognises it, it’s just a highlighting issue so no biggie if it can’t be fixed but it seems strange that the old editor was fine with it and the new one isn’t.

As the asterisk issue is fixed, I guess it wasn’t the same thing then?

Mark.


#9

But alias.column as a whole is an identifier and the period separates the two pieces. For lexing purposes the entire identifier is flagged as a single unit.

Ø
As the asterisk issue is fixed, I guess it wasn’t the same thing then?

Apples and oranges.

Michael

From: markagardner [mailto:bounce-markagardner@toadworld.com]

Sent: Thursday, June 25, 2015 10:36 AM

To: toadoraclebeta@toadworld.com

Subject: RE: [Toad for Oracle - Beta Discussion Forum] Auto-Replace no longer accepts special characters

RE: Auto-Replace no longer accepts special characters

Reply by markagardner

I’m not sure I understand what you mean when you say “A period is part of an identifier” - surely it’s a separator - it separates the alias from the column name. The behaviour of the old editor
(or so it seemed) was to treat a.Rowid as three things: the alias (a), the separator (.) and the column name (Rowid). The new editor (or so it seems) is treating it as one string and therefore not recognising the word rowid. Anyway, it doesn’t stop the code
working - the DB still recognises it, it’s just a highlighting issue so no biggie if it can’t be fixed but it seems strange that the old editor was fine with it and the new one isn’t.

As the asterisk issue is fixed, I guess it wasn’t the same thing then?

Mark.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - Beta
notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag
this post as spam/abuse.


#10

Did lexing not take place in previous versions of Toad?


#11

It did.

From: markagardner [mailto:bounce-markagardner@toadworld.com]

Sent: Thursday, June 25, 2015 10:50 AM

To: toadoraclebeta@toadworld.com

Subject: RE: [Toad for Oracle - Beta Discussion Forum] Auto-Replace no longer accepts special characters

RE: Auto-Replace no longer accepts special characters

Reply by markagardner

Did lexing not take place in previous versions of Toad?

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - Beta
notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag
this post as spam/abuse.


#12

Like I said, it’s not a biggie - I can live with it - but it just seems strange that you say it’s because of how lexing needs to treat the identifier yet the old version of the editor managed it fine.


#13

Michael - the auto-replace bug seems to be back in 12.8.0.9 - can you apply the fix again please?

Thanks,

Mark.


#14

And I’ve just noticed that s* which expands to select * from works if it is on the 1st line of the editor but not if it is anywhere else!