Toad World® Forums

Automate dcp file does not remember connection


#1

I create a dcp file for automation, which has connections to two Excel spreadsheets that has different values. Toad properly shows the differences, but when I save the dcp file, and reload, the differences do not get shown - I have to recreate the connection and mapping again. I have tried the auto connect on and off, but the only way this works is to recreate the entire mapping, which is of course no use for automation scripts. What is the solution please ?


#2

Hi,

thanks for your report unfortunately I will need more information to be able to help you. I tried several Excel files and compared them without problem. Also I tried use DCP file in Automation and I got same result.

Can you provide me what TDP version do you have? What is your Excel version and do you have problem with all excel files (can you create some sample Excel files and try it )? We need to know if problem is related to Excel version / data or if there is some problem in TDP functionality.

Thanks

Filip


#3

I have attached a zip file containing the two Excel spreadsheets and the Compare.dcp file that I use, also screen shots for what happens.

The scenario is:

  • Open the Compare.dcp file in toad
  • Choose “Compare immediately” - no errors shown
  • Open the “Change comparison Wizard” and see that the “Sheet 1” mappings have nothing selected
  • Select all the columns for each spreadsheet (See sheet1.png and sheet2.png in the zip)
  • Chose the column mapping (see mappings.png)
  • Complete and see that there are differences shown (see diffs.png and diffs2.png).
  • Finally, save the dcp file, close it, then reopen it - but no differences shown - and if I open the “Change comparison Wizard” again I see that none of the mappings that I chose have been retained.
    It seems that the problem is the mappings are not being saved in the dcp file, so each time I use it I have to choose them again.
    Compare.zip (250 KB)

#4

Hi,

I just investigated your issue and I found out that problem is on our side. I create task for QAT-12820 and we will fix it.

Problem is that your Excel file is not loaded correctly and we are not able refresh it after load. When you change configuration in wizard we have to load everything and we are not using your saved data (so this work as expected).

I found one workaround. It seems that problem is related to Excel files which has only one column for compare. If you will add for example ID column (1,2,3…) then it should start work. You can save your DC file and after load we should be able compare it. You don’t need to compare this new column or use for mapping. Would be great if you can confirm to me that it works for you.

Thanks

Filip