Toad World® Forums

Automation Scheduling Issues

Hi,

Can someone please post exactly how to schedule an automation script? I schedule scripts and they never kickoff at all. I had added a 2nd laptop that is always on at my desk for the sole purpose of distributing reports through TDP

Thanks,

Neil

The easiest way is to click on the Schedule button in the automation window and follow the prompt. The ones that have to be entered are 1) Your password as this will run under your user account and 2) when you want the task to run.

schedule1.png

schedule2.png

But I am going to assume you already did this. The best place to get info on what happened to a task is go to the windows task manager. ALL Programs | Accessories | Systems Tools | task scheduler. From there find your job and look at the Last Run Result column. What does it say in that column? If the scheduler couldn't start it might say why. If TDP actually ran but had a problem the error code would be 999, 111, or 222. The return codes might be in hex so you would have to convert.

Thanks for the help Debbie, I’m a big fan of your tutorial videos…

It appears the automation is kicking off properly in Task Scheduler (it was automated for 8am and then I manually ran the automation at 9:21am)

Capture.jpeg

However, I added an email and error log trigger and got the following error message… can you help?

– 5/8/2014 9:21:02 AM: Daily Reporting.log: Setting up environment
– 5/8/2014 9:21:02 AM: Daily Reporting.log: Script run by Toad Data Point 3.5.0.2936
– 5/8/2014 9:21:02 AM: Daily Reporting.log: Build started
– 5/8/2014 9:21:02 AM: Daily Reporting.log: Compiling script
– 5/8/2014 9:21:03 AM: Daily Reporting.log: Build completed
– 5/8/2014 9:21:03 AM: Daily Reporting.log: Begin execution script activities
– 5/8/2014 9:21:04 AM: Daily Reporting.log: Executing Automation Script: C:\Users\ndeciant\Desktop\Toad Reports\Update Table Script.tas
– 5/8/2014 9:21:04 AM: Daily Reporting.log: Update_Retention_Table - The path is not of a legal form.

– 5/8/2014 9:21:04 AM: Daily Reporting.log: Start error email

Can you open up that file in the version of TDP that is running the schedule? You might need to look at the task to see which TDP it is pointing to. Then run the script in the designer. Is everything Okay?

The error suggests that the xml in the tas file is not suitable for running. Either the file is corrupted or it is being run by wrong version of TDP.

If this does not debug everything, then turn on verbose logging and send me the full log and tas file.

Also, did you look at this video? It is just on debugging the scheduling of scripts.

www.toadworld.com/…/1120.aspx

Debbie

Follow up this conversion www.toadworld.com/…/1120.aspx

Debbie,

The only issue I can see after all your comments are in the task scheduler the actions tab looks like this:

I tried pointing program/script to the TDP 3.5 toad.exe file and added arguments -batch=true “C:\Users…script.tas” but still no luck

please send me your email so I can send you my files

Thanks,

Neil

The edit action dialog above looks wrong. As you mentioned you need to have the full path and the arguments surrounded in quotes. But since the task does seem to be running I will assume it is correct.

please send files to debbie.peabody@quest.com. Include *tas, any dependant files and automation log.