Toad World® Forums

Toad Automation Issue (TDP 3.3)

Greetings…

I have been experiencing this issue every now and then. Windows Task Scheduler indicates that the Toad automation scripts completed without any error. However, the scripts never ran.

Any thoughts on what might be the issue?

If you’re using Windows 7, this seems to be an issue with Toad and the new Windows Task Scheduler system that came with Windows 7 & Server 2008/R2.

I’ve yet to be able to get any TDP jobs to run unattended with our NT service account on our Windows 7 Enterprise test box.

Yes. It is on Win7. The scripts ran fine in TDP 3.3.

When the task scheduler says it ran but you did not get your reports, did you look at the log file to see what might occured? Did a log file of that date get created? I suspect that there may be something in the file that did not allow the script to finish yet no error was thrown. Can you look at the look file? And perhaps turn the logging to verbose? Another think to do is add " /log=all" to the command line that the schedular runs. This will turn on the toad.log file. This file can also be looked at to confirm that the scritp ran or did not.

For now, I reverted to running the scripts in TDP 3.3. I will setup few test scripts in 3.4 and follow your suggestions.

We have found the same issue and it also ran the report multiple times. I did find this support.microsoft.com/…/2461249

We ended up purchase a third party software to handle our task automation jobs.

Armand,

Can you share what you are using to schedule automation?

Thanks.

I have seen this post also. But for TDP automation scripts that run the task twice we found a different issue. The user had a layout that opened up the last windows used. So when the scheduled automation script ran, it ran twice. This is a different issue and covered in a different post. If this is your issue, go to options, select Desktops, and unselect Open documents.

Debbie.

I am using Windows Task Scheduler. Where should I add " /log=all" ? In the task scheduler?

Thank you.