Toad World® Forums

Scheduled automation script with success message but not actually running


#1

I set up some automation scripts to run starting at 3am, and they were running fine for a couple of days. Then I created a windows task to restart my computer at 8pm the night before, and when I checked the windows task scheduler this morning, all the scripts had a success message, but the run time was 4 seconds, so I don’t think they actually ran. I checked the automation log in the TDP 3.4 program files folder, and the last run for all of the scripts was from the previous day.

The scripts were set up for run when not logged in, and I entered my password correctly. The scripts are being run on a desktop, so I don’t have the wake computer option checked. The only thing that I did differently was I changed my password yesterday, but I updated it in the scheduler. I have the event viewer set up to log failed login attempts, and I didn’t see any during the time the scripts should have ran. I did not, however, see any successful logins either.

Now, I do log into this machine remotely quite often, but this has never seemed to affect the tasks before. Does anyone have any idea why the task to restart the computer might have affected things? Or is this just a coincidence?


#2

I rescheduled all of my scripts, and they started running correctly. Then as a test, I restarted my computer, and sure enough, the scripts stopped running correctly - for only 4 seconds. The toad icon pops up for a split second and then nothing. I first tried starting the task again, but that didn’t work, then I tried editing and reentering my password. But that didn’t work either. Finally I ran the script manually about 2 minutes before it was scheduled to run again. That completed as expected, and then it started again on schedule. This time it ran correctly. I don’t get it - why would the script all of a sudden start running after I run it manually?


#3

Just a suggestion. Can you go to Options -> Environment -> Desktops and make sure Open documents is unselected? If it was selected, unselect it and try your scenario again. Does it help?

Igor.


#4

This is already unchecked.


#5

Go to the windows scheduler and look at the last result column for each of the tasks. What does it say? Or can you post a screenshot? Make sure and expand the columns so I can see the numerical result as well as the text statement of the result.


#6

Hi Debbie - when this problem first occurred, I would see a success message, but it appeared that the script only ran for 8 seconds. I have not had this problem since I have left the computer running without restarting. Now you can see that the script runs for 49 minutes. Have you seen instances where a script runs for 8 or 9 seconds, but still says Success? I never received any error emails.

Come to think of it, I did have this happen the other day with another script, but it only did it once and then functioned correctly the rest of the day. I thought maybe there were some conflicting scripts running or something. Again, ran for 8 seconds but had a Success message. I hope this helps - this is the only information I can provide. If it happens again, I’ll try to give more detail.

toad task manager.png