Toad World® Forums

AW: AW: AW: ALT + Left/Right produce special character

Thanks Wim!
I am not using the numeric keyboard for this, but it seems to be related to
the problem:
When I disable Num-Lock, then the special characters are not inserted when
using Alt+Left/Right!
And with enabled Num-Lock, Alt+4 (numblock left) and Alt+6 (numblock right)
also produce the same characters (they do not navigate though).
Von: wimdelange_062 [mailto:bounce-wimdelange_062@toadworld.com] Gesendet: Montag, 2. Dezember 2013 16:21
An: toadoraclebeta@toadworld.com
Betreff: Re: [Toad for Oracle - Beta Discussion Forum] AW: AW: ALT +
Left/Right produce special character
Re: AW: AW: ALT + Left/Right produce special character
Reply by wimdelange_062 You are probably using the numeric keyboard which has also cursor keys.
That is the normal behaviour that you get characters, This has nothing to
do, as far as I know, with locales or keyboards. If I type something like
Alt-153 I get the old symbol for Gulden: ƒ.
You want a hard Form Feed (nice if you print this email in certain
environments :slight_smile: use Alt-12 that insers a Ascii 12 character. ♀ Alt-65
gives an uppercase A. Alt 64 (or Alt- right-left) gives @
It is possible that the Alt-12 is not visible in your emailer.
Groetjes,
Wim
google.com/+WimdeLange 2013/12/2 Peter Lang >
AW: AW: ALT + Left/Right produce special character
Thread created by Peter Lang - There is no Shortcut beginning with Alt
Is this what you mean by auto replace settings (previous mail)?

  • There is also no Editor > Behavior > Key Mapping beginning with
    Alt
    Shouldn’t Alt-Left/Right be defined as Shortcut or Key Mapping?
  • My Editor font is Courier New, but changing it to Arial does not
    help with the problem
    It does not happen when I open a new instance of TOAD and use
    Alt+Left/Right in the empty Editor window (since there is no navigation
    possible).
    I could also not reproduce the behavior in any other application.
    When using my example below, I cannot produce the special character twice
    by pressing Alt+Left twice (since only one navigation is possible).
    Von: Brad Boddicker [mailto:bounce-ButtonPusher@toadworld.com
    ] Gesendet: Montag, 2. Dezember 2013 15:33
    An: toadoraclebeta@toadworld.com Betreff: RE: [Toad for Oracle - Beta Discussion Forum] AW: ALT + Left/Right
    produce special character
    RE: AW: ALT + Left/Right produce special
    character Reply by Brad Boddicker Go to options > Toolbars/Menus > Shortcuts. Sort by the “shortcut” column.
    Do you see anything beginning with “Alt” in there?
    What is your Editor font? (Options > Editor > Display > Fonts)
    From: Peter Lang [ mailto:bounce-PeterLang@toadworld.com] Sent: Monday, December 02, 2013 9:29 AM
    To: toadoraclebeta@toadworld.com
    Subject: [Toad for Oracle - Beta Discussion Forum] AW: ALT + Left/Right
    produce special character
    AW: ALT + Left/Right produce special character Thread created by Peter Lang Hi Brad,
    Locale German (Germany), Keyboard German
    I also tried to switch to “English (USA), Keyboard US”, same behavior.
    Also does not make a difference if I use my Laptop-Keyboard or the
    USB-Keyboard.
    And this also happened with my previous workstation
    Anything else I can provide?
    Best regards, Peter
    Von: Brad Boddicker [mailto:bounce-ButtonPusher@toadworld.com] Gesendet: Montag, 2. Dezember 2013 15:04
    An: toadoraclebeta@toadworld.com
    Betreff: RE: [Toad for Oracle - Beta Discussion Forum] ALT + Left/Right
    produce special character
    RE: ALT + Left/Right produce special
    character Reply by Brad Boddicker Peter,
    What is your locale set to? What about your keyboard?
    Thanks,
    Brad
    From: Peter Lang [ mailto:bounce-PeterLang@toadworld.com] Sent: Friday, November 29, 2013 6:43 AM
    To: toadoraclebeta@toadworld.com
    Subject: [Toad for Oracle - Beta Discussion Forum] ALT + Left/Right produce
    special character
    ALT + Left/Right produce special character Thread created by Peter Lang When using ALT + Left/Right to navigate after jumping with CTRL+Click, a
    special character is inserted after releasing ALT-Button.
    Steps to reproduce:
  1. Post the following code (no need to compile)
    CREATE OR REPLACE PACKAGE BODY test_package AS
    PROCEDURE test_procedure AS BEGIN NULL; END test_procedure;
    BEGIN
    test_procedure();
    END;
  2. Ctrl+Click the call of test_procedure (jumps to declaration).
  3. Use ALT+Left to navigate back
    When releasing the ALT-Key, the following character is inserted: :diamonds:
    Using ALT+Right afterwards adds this one: :spades:
    That’s what the code looks like afterwards:
    CREATE OR REPLACE PACKAGE BODY test_package AS
    :spades:PROCEDURE test_procedure AS BEGIN NULL; END test_procedure;
    BEGIN
    test_proc♦edure();
    END;
    To reply, please reply-all to this email.
    Stop receiving emails on this
    subject.
    Or
    Unsubscribe from Toad for Oracle - Beta
    notifications altogether. Toad for Oracle - Beta Discussion Forum Flag
    this post as spam/abuse. To reply, please reply-all to this email.
    Stop receiving emails on this
    subject.
    Or
    Unsubscribe from Toad for Oracle - Beta
    notifications altogether. Toad for Oracle - Beta Discussion Forum Flag this post as spam/abuse. To reply, please reply-all to this email.
    Stop receiving emails on this
    subject.
    Or
    Unsubscribe from Toad for Oracle - Beta
    notifications altogether. Toad for Oracle - Beta Discussion Forum Flag
    this post as spam/abuse. To reply, please reply-all to this email.
    Stop receiving emails on this
    subject.
    Or
    Unsubscribe from Toad for Oracle - Beta
    notifications altogether. Toad for Oracle - Beta Discussion Forum Flag this post as spam/abuse. To reply, please reply-all to this email.
    Stop receiving emails
    on this subject.
    Or Unsubscribe from Toad for Oracle - Beta
    notifications altogether. Toad for Oracle - Beta Discussion Forum Flag
    this
    post as spam/abuse. To reply, please reply-all to this email.
    Stop receiving emails
    on this subject.
    Or Unsubscribe from Toad for Oracle - Beta
    notifications altogether. Toad for Oracle - Beta Discussion Forum Flag
    this post as spam/abuse.