Toad World® Forums

Bug: PROCESS permission needed


#1

I am trying to compare schema but receive an error that the PROCESS permission is needed.

I have developed my own schema analysis tools before and I am 100% sure that this permission isn’t needed as my tools are able to analyse the schema using the same account without any problems.

There’s something it’s doing that needs that permission that it should be possible to enable or disable. Unfortunately when the error occurs it gives no indication of on which sub-step or even the query (presumably it’s trying to view the process list though).

This is disappointing because the main reason to use this tool and pay for it is the schema compare (which doesn’t support multiple databases at once as well and the data compare appears to have gone).


#2

Hello Joey,

What version or Toad Edge are you using? Some of our internal loading queries used to require PROCESS privilege to work. This has since been changed, so I would recommend trying the newest version to TE to see if that fixes the problem.


#3

Hello Joey,

What version of Toad Edge are you using?

Some of our loading queries used to require PROCESS privilege, but that has since been changed. I would recommend that you try the newest version and see if that fixes the problem,