Toad World® Forums

Bug When Editing Export Templates

I have verified the following issue in both version 5.2.0 and the latest 5.2.1. If you create an export template from Oracle (probably other sources, but I deal mainly with Oracle) for use in an Automation and set the export to generate a CSV in UTF-8 as shown below:

image

If you then open the .txp file in a text editor you will see the following settings in the file as one would expect:

Encoding="Unicode (UTF-8)"

If you then open the .txp file in TDP and add a second extract to it with the same settings as shown above and save the Template, the original extract which you did not edit gets altered, when you open the .txp file in a text editor, you will now see the following settings for the extract that was not edited:

Encoding=""

If Encoding="Unicode (UTF-8)" the resulting file contains the UTF-8 characters and does not start with a BOM. If Encoding="" and there are no UTF-8 characters in the extract the file is created as ASCII, but when UTF-8 characters are in the result, the file gets generated in UTF-8 format with a BOM at the beginning. I am feeding the extracts into a tool that correctly handles UTF-8 characters, but can not handle the BOM at the start of the file.

If you open the Template in TDP, and edit the specific extract that had Encoding set to "" it appears on the screen as if set correctly. If you check/uncheck a setting on the screen so the process registers a change and click next so the .txp gets saved again, now the one you edited in that session is corrected but all other extracts in that .txp get Encoding set to "".

For now, every time I alter a .txp in TDP, I have to go behind in UltraEdit and verify Encoding is correct everywhere.

Thanks for your Help and let me know if you need any additional details...

I'll try and reproduce this one too. Thanks for your post.