Toad World® Forums

how to save a file in UTF-8 encoding without the Byte Order Mark (BOM) first byte

Good Morning,

My name Tam Dam and I’m a programmer/analyst for the Alamo Colleges in San Antonio, TX.

We’re using Toad for Oracle Professional, rel. 12.0.0.61.

I have to export a table to a tab-delimited (.tsv) file from an SQL script using Toad editor with UTF-8 encoding

to send it to our vendor for processing.

However, the vendor can’t process our file due to the Byte Order Mark (BOM) as the first byte embedded at the beginning

of the file due to the UTF-8 encoding that comes at the vendor’s request.

I’m including the script below and the output (attached):

select RTVFSRC_CODE,

   REPLACE(RTVFSRC_DESC,CHR(9),CHR(32)) "RTVFSRC_DESC",

   RTVFSRC_IND,

   RTVFSRC_ACTIVITY_DATE,

   REPLACE(RTVFSRC_USER_ID,CHR(9),CHR(32)) "RTVFSRC_USER_ID",

   RTVFSRC_SURROGATE_ID,

   RTVFSRC_VERSION,

   REPLACE(RTVFSRC_DATA_ORIGIN,CHR(9),CHR(32)) "RTVFSRC_DATA_ORIGIN",

   RTVFSRC_VPDI_CODE

from RTVFSRC

order by 1;

Is it possible to turn off the BOM when saving a tab-delimited (.tsv) file with UTF-8 encoding from an SQL script output ?

Currently, it’s the default and only option (that I know of).

Thank you for your help.

Regards,

Tam

210-485-0468
rtvfsrc.tsv (431 Bytes)

Any item you save should have the Encoding option of UTF-8 (no BOM) available. Simply choose that instead of UTF-8.

Greg

From: tdam [mailto:bounce-tdam@toadworld.com]

Sent: Monday, June 16, 2014 11:05 AM

To: toadoracle@toadworld.com

Subject: [Toad for Oracle - Discussion Forum] how to save a file in UTF-8 encoding without the Byte Order Mark (BOM) first byte

how to save a file in UTF-8 encoding without the Byte Order Mark (BOM) first byte

Thread created by tdam

Good Morning,

My name Tam Dam and I’m a programmer/analyst for the Alamo Colleges in San Antonio, TX.

We’re using Toad for Oracle Professional, rel. 12.0.0.61.

I have to export a table to a tab-delimited (.tsv) file from an SQL script using Toad editor with UTF-8 encoding

to send it to our vendor for processing.

However, the vendor can’t process our file due to the Byte Order Mark (BOM) as the first byte embedded at the beginning

of the file due to the UTF-8 encoding that comes at the vendor’s request.

I’m including the script below and the output (attached):

select RTVFSRC_CODE,

  REPLACE(RTVFSRC_DESC,CHR(9),CHR(32)) "RTVFSRC_DESC",

  RTVFSRC_IND,

  RTVFSRC_ACTIVITY_DATE,

  REPLACE(RTVFSRC_USER_ID,CHR(9),CHR(32)) "RTVFSRC_USER_ID",

  RTVFSRC_SURROGATE_ID,

  RTVFSRC_VERSION,

  REPLACE(RTVFSRC_DATA_ORIGIN,CHR(9),CHR(32)) "RTVFSRC_DATA_ORIGIN",

  RTVFSRC_VPDI_CODE

from RTVFSRC

order by 1;

Is it possible to turn off the BOM when saving a tab-delimited (.tsv) file with UTF-8 encoding from an SQL script output ?

Currently, it’s the default and only option (that I know of).

Thank you for your help.

Regards,

Tam

210-485-0468

Attachments:

rtvfsrc.tsv

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

In the save dialog set the encoding to UTF-8 (no BOM). You can make that the default encoding in Options on the Files|General page.