Toad World® Forums

Cannot create new columns with Number(8,2) in Oracle

Hello, I have a very strange situation: I’m trying to add a column to an existing table.

I add the column, then select “Number(x,y)” as the datatype and then specify 8 for the Precision and 2 for the scale. But as soon as I close the dialog with OK (or use “Apply”) the scale value is removed. This seems to happen for all values of scale/precision (I tried several combinations apart from 8,2)

I have many other columns in the model (and in fact one other column in that specific table) which are defined as Number(8,2) so I am completely surprised that I cannot change the type as I want. But it seems that I cannot define that for new columns. It does work however when I define a Domain with those attributes and then use that domain as the datatype - but that’s not want I want to use right now for several reasons.

I also restarted TDB just in case, but still no go.

Any idea what could be wrong? I’m using TDM 5.0.5.31 could that be a bug in that version?

It’s a customer’s model, so I cannot post it here unfortunately.

Hi,

This really is/was a known bug (#110780) and is already fixed in TDM 5.1.

Regards,

Lukas

Thanks for the quick reply. I didn’t notice that 5.1 was already released.

You’re welcome! There were two releases in short time, the other, 5.1, with only Oracle 12c support added and a couple of bug fixes that shouldn’t wait for another release…