Toad Intelligence Central adding decimals to integers


I am converting over 100 toad scheduler jobs from toad to TIC. The excel reports are coming out with 5 decimal places on Integer fields.

I have tried settings grid number an integer tabs using every option available, but nothing works.

Anyone else resolved this?


Are you using the latest 6.1 version of TDP by chance? Many issues like the one you are describing have been fixed in that release.

Hi Gary,

Thanks for your response.

I am using TDP (64 bit)

I have a case open with Quest, had a video conference with Quest yesterday. Quest is taking it back to the lab to see if they can replicate the problem.

It works in TDP properly but does not work when run from TIC Toad Intelligence Central. In TIC it brings in 5 decimal places on all integer fields.

Thanks again for your response,

Will let you knkow what

THanks for keeping the forum in the loop.

I'm just curious... any one else seeing this same effect with unwanted decimal places in similar scenario?


Sulaiman Ramli (at AT&T) met with me yesterday and figured out the likely cause of all those decimal places. The primary keys in my ORACLE database are defined as NUMBER (15,5). We tested with columns defined as Number with nothing after the comma and they worked fine. So "Sully" suggested changing my sql to use Round(column-name) on the columns so defined. Was hoping for just a simple tweak to TIC, but in the meantime, I will put Round onto those columns.

Much appreciate the status and work-around.

Yes, in general, TDP and TIC typically respects the datatypes and formatting attributes as the solution lifts off the data from the databases. Of course, there are many places where data presentation can be manipulated... via functions within SQL, via Transform & Cleanse, when exporting the data to other formats, etc.