Toad World® Forums

Large Numbers Output


#1

Hi all,

I think i have a problem, can you help me, please?

On TOAD 11.6 data grid:

column01 column02

30-06-2013 96000002731901
30-06-2013 96000010000001
30-06-2013 96000010000050

On TOAD 12.0 data grid:

column01 column02

30-06-2013 96000002731901,0048
30-06-2013 96000010000000,9984
30-06-2013 96000010000049,9968

What am i doing wrong???

Thanks,


#2

work arround

I changed data type from NUMBER(14) to NUMBER

Still missing why it works on version 11.6…


#3

Are you executing the query using F5 for F9?

From: nr_mendes [mailto:bounce-nr_mendes@toadworld.com]

Sent: Friday, July 05, 2013 7:26 AM

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] Is this a BUG???

RE: Is this a BUG???

Reply by nr_mendes

work arround

I changed data type from NUMBER(14) to NUMBER

Still missing why it works on version 11.6…

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


#4

Ctrl+Enter


#5

Do you have the same setting for scientific notation in both versions of Toad? That is just a guess. I am not sure that it would affect rounding.

From: nr_mendes [mailto:bounce-nr_mendes@toadworld.com]

Sent: Friday, July 05, 2013 6:32 AM

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] Is this a BUG???

RE: Is this a BUG???

Reply by nr_mendes

Ctrl+Enter

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


#6

hi,

they are all, 11 and 12, unchecked

Thanks


#7

For me, in both versions, unchecking the “Scientific notation” option makes the decimal values appear. Checking makes them go away in both versions.

Are you using the same Oracle Client in both Toads? Also, what version of Windows are you using?

I am not sure what else to ask, but I suggest that if you want to be sure to not see the decimal values, then you should add a ROUND() in your query, or make sure that the decimal values do not get into your data in the first place.


#8

Hi,

And the column in the table is NUMBER(14)?

Windows XP

Version 2002

SP3

Thanks,