Cannot open the same .sql file in the same instance of TDP and two instances of TDP not working.

Im using TDP 3.6. I’m trying to run the same .sql file twice (essentially for two databases) at the same time to run them together to increase productivity running queries. It doesn’t seem like an instance of TDP will allow me to open the same .sql file twice in the same instance. Therefore, I went to the general settings and checked “Allow multiple copies of Toad to run”. This allows me to open up a second instance of Toad. Lately though, when I do this, the second instance does come up, but I’m continuously getting the error message when its trying to establish my connections "Couldn’t open file for connection trace. Disabling trace. The second instance wont allow any connections after that and I have to just shut it down. Do you think this could be a known issue? If so, could someone check it out and see if I need to enter a ticket with Dell regarding it? Also, if there’s a way to allow the same .sql file to open in a single instance that would be probably quicker and more efficient.


Chad King

There shouldn’t be any issues with opening and using the same SQL file. You just wouldn’t want to write to it. The error message sounds more like a logging file in TDP. See if you have TDP connection tracing enable and if so turn it off.



That did help regarding opening the second instance of TDP. I’m guessing this is the only way to run the same .sql file multiple times. Essentially you cannot bring up the same .sql file on the same instance of TDP correct? Thanks for this though, it does make it so I can do it, just have to open multiple instances of TDP to accomplish it.


Yes, this is the only way to do this. Our code wants you to associate the file to one open editor. It is making the assumption that you want to edit the file.

Why don’t you use an automated job with a parrallel with connection 1 on one side and connection 2 on the other side. Then put the same select to file, execute script or export/import wizzard inside each. Then all you have to do it run the job.

Thanks Debbie, that’s good enough for me. I’ll just make sure to open a second instance of TDP to run the same .sql more than once and since I know now how to shut that tracing off, I’m good to go.

Greg, I’m not sure I have to get that in depth, just really need the ability to run the same query for different databases at the same time sometimes. Debbie’s solution regarding tracing is very helpful and I think should work as a solution to this.

Thanks again.