Toad World® Forums

Can't get command line schema comparison working on Toad 12


#1

I am using Quest Toad for Oracle with the DB admin module version 12. We use the schema comparison to compare schemas and create sync scripts. We have over a large number of clients to support so when updating our software we need to compare local versions of our database on the latest version of our database development with copies of the clients test and production databases so we can ensure the sync works before roll out to clients.

Currently we have 13 schemas to compare per database so a manual schema compare requires login 26 times under each schema to compare databases. I want to run this comparison from the command line changing the details of the database and the schema using the -c option for both the source and target.

I have used the Automation designer to setup a comparison and then I have tried running this from the command line in the format “\toad” -c /@ /@ -a “<compare.ini>” where I can replace the schemas, passwords and databases. The passwords are in plain text.

Originally I set this up on Toad 10.6 but couldn’t get it working, so I upgraded to version 12 but I have the same issues.

If I run it against the databases originally setup in the comparison in the automation designer it works. As soon as I change the details in the command line it either doesn’t work, or ignores what i have passed in and runs the comparison based on what I originally setup. I have tried editing the .ini file to use the databases I want to compare but again without success.

I have tried swapping the order of the -c and -a parameters and I have tried putting the second connection details in quotes but I just can’t get it to overide the original settings. I have searched the internet and forums and not found a solution that works. I looked through the help but there and no command line examples for a schema compare where you pass in two connection details and this is what I think I am missing.

In toad I have save passwords set to off as I want it to use what I pass in as they change over time, not what is stored as some databases I may not have connected to through Toad before I try and compare them from the command line.

The command line gives no feedback on errors so I have been checking the toadactions.log but the information is very sparse and all I usually get is a message like “Cannot connect to @” where the DB is the one setup in the Automation designer and not the one I passed in.

I am sure there is something fundamental I am missing can anyone please help.

Regards,

    Mark

#2

Hi Mark,

I made two replies by email to your message, but somehow they got created as separate threads. I am replying now through the web interface so hopefully this will work better.

please see

www.toadworld.com/…/19814.aspx

and

www.toadworld.com/…/19815.aspx