Toad World® Forums

toad for Oracle command line

Hi

After creating a sample app I am trying to run Toad.exe -a “App3->Compare Schemas1” from the command line.
After creating a default app I am trying to run Toad.exe -a “App4->Compare Schemas1” from the command line.

While running the command Toad for Oracle application is not open.

Just like how the GUI starts the extraction followed by comparision and populates the diff summary, diff details and sync script I would like to use the command line to do the same.

The command line does not open Toad for Oracle application. It appears like the command line does not do anything as of now even if the command is run repeatedly.

Please help with command line comparision of two schemas using Toad for Oracle command line.

Toad for Oracle Xpert 64 bit Add ons DB Admin module Version 12.9.0.71

Oracle database Enterprise Edition version 12c release 1
Please let me know if there is any other information required.

Thank you

The GUI doesn’t become visible when you run actions from command line. The work should be done and output files should be created without the GUI. Take a look at your action and make sure that you have output files defined.

Hello,

Thank you for your response. Is there some place where I can see what exactly is the current action? Like in the GUI. The GUI shows “Extracting Source database tables DDL”, “Extracting Source database tables default values DDL”, “Extracting Source database constraints DDL” etc.

I have defined the output files(diff summary, diff details and sync script) in the action.

Thank you

Not while it is running, no.

But when it is done, you can start Toad manually, then go into the automation designer. Click on “Execution Log” on the left, then find your action and select it. If it failed for some reason, you should see some explanation in the bottom.

Dear All,
I am building a small app for my office people where i have given option to connect to different db. As per Toad guidelines, multiple connections(from command line) can be made via --> -c schema/password@db "schema2/password@db as sysdba". I have tried same command via command line first(connecting to db via TNS):
C:\Program Files (x86)\Quest Software\Toad for Oracle 12.1>Toad.exe -c swb@rajesh "swb@kumar". It is only connecting with first db which is rajesh. Can anyone help me, what i am missing here ?

I believe it will only work without passwords if the password is saved in your login window.

Does it work if you add passwords to your command line?

Thanks @JohnDorlon: with password it worked. Then again i tried without password(pwd was saved in Toad) it works fine.
Can you also tell me how to connect to toad from command line without having the TNS entries in place? Currently i am making TNS entries and then connecting to toad which is working fine.

Suppose, i have host,port,service name, userid and pwd. how can i pass all these arguments and connect from command line ?

just as you would with sql plus. username/password@host:port/service_name

I tried the way you told me: i getting below error constantly

"Access violation at address 057F4E1C in module 'Toad.exe'. Read of address 00000060". What does it mean? I have attached Toad.log file for your reference.
I tried to connect to a saved connection via your method[username/password@host:port/service_name], it is getting connected but only for new connection it is giving me the error i mentioned.

Toad.log (2.4 KB)

I don't know why you are getting the AV. Unfortunately, that log file is not helpful.

I got connected like that without error, but I was using the current Toad version. Toad version 12.1 is quite old. It could be that there is some error here that I have forgotten about. You could also try a full TNS string like
user/password@(DESCRIPTION=(ADDRESS=(PORT=.....)(HOST=......)(PROTOCOL=TCP))(CONNECT_DATA=(SERVICE_NAME=.....)))

Unfortunately, getting same error again even for the already saved connection in toad. Screenshot below:

image

Sorry. :frowning:

You could try resetting your user files but that will cause you to lose all settings in Toad. If you want to try that, go to Main Menu -> Utilities -> Copy User Settings. Choose "Reset to a clean set of user files" and click OK. Toad will restart. The old user files will be renamed with "_bak", so you can restore them later if you want. Just be sure to do that with Toad not running.

If that doesn't work, and you need to get past this, then you'll have to upgrade your Toad.

ok thanks captain!

Hi @JohnDorlon: I have a scenario: I am trying to connect Toad from vb.net. I am passing the arguments to cmd. It is opening the exact connection if the arguments are right. But it is only opening Toad if the arguments are incorrect ex: password is incorrect.
Can you help me with this or should i ask this in another forum?

You are in the right place, but I can't change the way Toad 12.1 works.

This may help: If you store the password on the login window, and you intend to run an action....just call the action from command line w/o the connection info. Toad will automatically make the connection for that action.