Toad World® Forums

Can't open TDM after upgrading to Windows 10

Hi all,

I was running Toad Data Modeler (version 6.0.3.14, 64-bit) with no problems under Windows 7. My laptop was reimaged with Windows 10 last week, and after reinstalling and trying to open TDM, I get an application error saying “Basic definition of package can’t be loaded!My Package.” Uninstalling/reinstalling makes no difference – the installation runs without error, but I can’t open the program. My account is an administrator on the laptop, but there are also network group policies in place (although those were in place under Windows 7 as well). Has anyone else run into this problem, or do you have any ideas about what might be causing the issue?

Hello Sacklunch,
It’s look like problem with loading “My Package.txg”. This is basic user package, that is required for Toad Data Modeler. By default is located at
“c:\Users\XXX\Documents\Toad Data Modeler\Standard Installation\Packages{DCB5CB9B-CF65-4350-86B5-285D246FC5AC}”. This path can be changed by TDM settings.
Your actual settings is located at “c:\Users\pdaricek\AppData\Roaming\Dell\Toad Data Modeler\Configuration X\Configs”. In this folder is file Application.txc (it is xml file). In this file is xml tag “PackagePath”. Please check this path.
You can try delete settings and “My Package.txg” too (if you have some user modification of this package, please backup first). During next run of Toad Data Modeler, will be copy default configuration files and empty “My Package.txg”.

Daril

THANK YOU!!! Deleting “My Package.txg” worked, at least for now! I’m kind of suspecting the problem will return, because in troubleshooting this I deleted my entire Windows 10 profile and re-created it, and the problem occurred under both profiles. Anyway, that was extremely helpful!

It’s interesting: in that packages directory, the existing “My Package.txg” file was dated 6/7/2016, so it wasn’t configured as part of my install this week. There’s also a file called “My Package.~txg”, dated 4/2/2010. When I renamed the original “My Package.txg” and restarted TDM, it looks like it made a copy of “My Package.~txg”: the new “My Package.txg” file is also dated 4/2/2010. As I say, it seems to work for now, but do you know what’s in these files, or where the original version came from, or what might be wrong with it? They’re very different files – the one I renamed contains many more lines, but I don’t know what this is controlling. If you can offer any additional info about that, please do. Otherwise, thank you again!

I think I figured out what happened here, so I’ll write this up in case someone else runs into the same issue. When they reimaged my machine, they first backed up my Documents directory, then later restored it. Since TDM keeps config information in that Documents directory, I ended up with a confusion of config files from both the Win7 and Win10 installations. I uninstalled TDM, deleted that “C:\Users\xxxx\Documents\Toad Data Modeler” directory, reinstalled TDM, and everything seems good now!

Hello scklunch,
I glad to see, that your problem is solved.
A small background. Toad Data Modeler has some functionality stored in TDM packages (*.txg). Major of them are system packages, designed by TDM developers and stored in Install folder. “My Package.txg” is default package for user customization. You can store in it your script, macros, forms modification and other. This package is stored in user documents folder by default: “c:\Users\XXX\Documents\Toad Data Modeler\Standard Installation\Packages{DCB5CB9B-CF65-4350-86B5-285D246FC5AC}” (you can have instead “Standard Installation” other folder, this name is entered during first start of TDM by dialog).
When you uninstall Toad Data Modeler Standart Installation folder preserve. It’s folder with user output documents and some customization. It is not desirable delete it.
Now, when you install another instance of TDM and do first run you will see this dialog:

5125.FirstRun.png

Now you can use some files configuration from previous or existing installation of TDM or check “New Configuration” and use defaults.

Daril