Toad World® Forums

Toad Data Modeler not working


#1

Hi - I purchased Toad Data Modeler a little over a year ago and it was working fine on my machine. Within the past week it started giving error messages and doesn’t work now. The application opens but when I try to open a model it gives these errors:TDM_ErrorMsgs.png

Nothing new has been installed on this computer lately. Why would TDM do this when it was working fine before? What can be done to fix this?

knot22


#2

Hello - which version of Toad Data Modeler are you using?


#3

4.3.3.6 – it’s the trial version in case that makes any difference

**Nick WHITE
**Senior Consultant

Sopra ** * group*****.**

8th Floor

55 Old Broad Street

London. EC2M 1RX

Phone :

Mob : 07917648966

Nick.White@uk.sopragroup.com
www.sopragroup.co.uk

P Before printing, think about the environment

From: Kevin Stern [mailto:bounce-KevinStern@toadworld.com]

Sent: 07 June 2013 16:42

To: tdm@toadworld.com

Subject: RE: [Toad Data Modeler - Discussion Forum] Toad Data Modeler not working

Hello - which version of Toad Data Modeler are you using?


#4

Kevin - The version I’m using is 4.1.5.8 This is NOT a trial version - I purchased it and loaded it only my machine using the CD.


#5

If you are still under support, you are entitled to download a newer version of Toad Data Modeler - version 5.0 just released this week in fact!

If not or if you’d rather not upgrade, I would suggest trying to re-install the product. These types of errors are usually related to another component in the system being upgraded and causing a DLL incompatibility. Re-installing the product in many cases fixes this issue.


#6

I will attempt a re-installation. To save the models that I already have (so they can be used once TDM has been re-installed) do any files other than the .txp files need to be saved?


#7

Hi,

the JScript.dll error message might be caused by an update of your OS. Toad Data Modeler users Microsoft Scripting Engine, a standard part of Windows. In past, update of Internet Explorer caused changes in OS and affected other applications, including Toad Data Modeler. We will certainly do additional tests and try to find solution.

Did you install new version of IE or did you update your OS?

Thanks,


#8

Hi Vaclav - The only thing that I’m aware of is Notepad++ was updated recently (6/3/13) on the machine in question. Automatic Microsoft updates occur from time to time as well - not sure if those affect anything. IE is set to install new versions automatically but I’m not sure the last time a new one installed itself. IE 10 is what is currently on the machine.

Are there any files other than the .txp files that need to be saved in order to use the models I already have once TDM has been re-installed?


#9

P.S. The version of Notepad++ that is now on the machine is 5.9.6.2.


#10

Notepad++ will not affect nor interfere with TDM. I use notepad++ myself and update it almost monthly (when they have updates) without issue ….

Bert Scalzo

Engr Tech Principal Engineer

Dell | Information Management

office
+1 469 888 5302

fax
+1 949 754 8999

cell+1 469 693 3300

Quest Software is now part of Dell

From: knot22 [mailto:bounce-knot22@toadworld.com]

Sent: Saturday, June 08, 2013 3:11 PM

To: tdm@toadworld.com

Subject: RE: [Toad Data Modeler - Discussion Forum] Toad Data Modeler not working

P.S. The version of Notepad++ that is now on the machine is 5.9.6.2.


#11

Bad news. I uninstalled the original TDM and reinstalled it from the CD. The application will open but when I try to create a new model the following error message appears:

TDMerror.png

Now what should be done to try and get it to work?


#12

Hi,

we did tests on multiple machines, on various operating systems with different versions of IE… and found no issues.
Unfortunately, we are not able to reproduce it.

What version of JScript.dll do you use, please? (Try to find the file on your OS, right click the file and see product version on tab Details)

Possible workaround: The JScriptl.dll library might be damaged and using different JScript.dll file might fix the problems.

Users of other applications seem to have similar problems and some sites offer download of JScript.dll file as a workaround.

Try to search “jscript.dll download” in your favorite search engine.

Regards,


#13

Hi Vaclav,

Thank-you for the information to try and help solve this problem. Here is the version that’s on my machine:

JScriptFileProperties.png

It is indeed different from the one in your screenshot. The other interesting thing I noticed about this file is the Date Modified date and time. It appears to have been updated recently. It must be one of those files that gets updated automatically, since I’m certain that I did not proactively update it.

Are you able to reproduce the problem with this version of the JScript.dll?

What do you recommend doing at this juncture? Still use a different JScript.dll downloaded from the internet?


#14

Hi,

thanks for the info. Unfortunately, we do not have this version of JScript.dll at our disposal. If you add it to zip archive and either attach it to this thread or send it to modeling@quest.com, we will test it.

You might also try to revert back to previous version of the file. On your screenshot you can see that the last tab allows you to revert back to previous versions, considering at least one Restore Point exists. If not, then you can try to search jscript.dll in Windows folder and use a copy of older version.

jscript-old-versions.png

Please backup the file before you overwrite it with older version.

I hope it helps and please let us know results.

Thanks,


#15

Sent the zipped file to e-mail address provided. I’ll have to attempt the restore later today when there’s a bit more time to work on it.


#16

Hi,

thank you. We made test on Win 8 machine and the JScript.dll you sent us worked fine. Did you try to use older JScript.dll library?

And one more question: what anti-virus software do you use, please?

Thank you,


#17

Here is a screen shot of what the restore looks like for this file - notice how the restore button is disabled…

RestoreButtonDisabled.png

This machine has McAfee anti-virus software on it. It is running Windows 7 for the OS.


#18

There is a previous version of the file available. Is there a way to enable the Restore button?


#19

Thank you for sending us details. We tested McAfee several times and found no problems, but will do additional tests.

I do not know how to activate the Restore button, it might be locked by OS or some other prouduct, certainly not by Toad Data Modeler. I tried to search some solution via google search, but didn’t find simple solution.

Regards,


#20

The same thing has started to happen with me. Out of nowhere my IE has decided to update itself to version 10 (probably by some sys admin remote command) and as soon as that happened Toad stopped working, showing me that same access violation message on jscript.dll.

Judging by the date knot22 posted the problem, I think that it was the same Windows Update that has caused this problem for both of us, since the last big one happened this Tuesday. That, of course, assuming that the Windows Update is the responsible for this mess (if I had to bet, I’d say yes)

I am on Windows 7 64 Professional (pt-br)

Toad Data Modeler 3.4.15.10

IE10

jscript.dll 5.8.9200.16611 (pt-br)

If you need more info, just ask