Toad World® Forums

Can't run Toad Edge Preview due to Authentication Issue


#1

When I installed Toad Edge Preview I did not get the login screen that is shown in this blog entry, https://community.toadworld.com/products/toad-edge/b/weblog/archive/2018/03/19/using-toad-edge-preview-2-0-0-with-postgresql-10 . Also when I launch Toad Edge Preview I don’t get a login screen - I only get the Online Authentication Failed window. When I click Sign In I get the same thing - but I never see a place to enter the username and password. Where should the credentials be coming from?


#2

The credentials or login is an HTML page. What I can think of, could be your pop-up blocker is on? Check your browser settings and make sure to turn off pop-up blocker and try again.


#3

I set quest.com and toadworld.com in the list to allow popups and that didn’t work. In a support chat now trying to figure this out.


#4

Registration is required. Is an account registered? If not, please first create an account at community.toadworld.com/…/createuser


#5

I am getting the same thing. I allow popups and I belong to ToadWorld. At first I only belonged to DB2 and Oracle… so joined Toad Edge Community as well… that did not resolve the issue. If anyone has a solution please pass along.


#6

Mine works well. Although in the beginning I had to re-authenticate when my work machine was decommissioned and I was given another one.

Anyway, you would need a Quest account. Which should be the same one that you can use to log on to ToadWorld community. I would double check that your account that you are referring to is from Quest. They give you a Quest ID behind the scenes I believe.

If that doesn’t seem to work, I’d try the old uninstall install bit. Just do you work backups where necessary.

Goodluck.


#7

Mine ended up being a firewall/certificate problem with my work firewall. When I tried it from home I was given the login screen and I was able to get into the software. Since it only requires you to go through that step every 30 days I’ve been able to launch it from work without an issue as long as the 30 days is up.


#8

As mentioned before registration is required. Is an account registered? If not, please first create an account at community.toadworld.com/.../createuser


#9

Hi, this is known issue with user behind a proxy, where proxy uses untrusted certificates. Right now, user has to manually export that certificate into a file and then insert it into Java cacerts file.

Located here: c:\Program Files\Quest Software\Toad Edge\lib\jre\lib\security\

Here is the way how to do it:

https://stackoverflow.com/questions/11617210/how-to-properly-import-a-selfsigned-certificate-into-java-keystore-that-is-avail

In upcoming release it will be possible to add it into the Toad Edge directly

br.

Miroslav Stanik


#10

Hi, we have released Toad Edge Preview 2.0.1 where we improved the workflow for this issue.

We really appreciate if you try this version without added certificate in your cert store.

Just download the preview here: https://community.toadworld.com/platforms/postgres

thank you very much

Miroslav Stanik


#11

Thank you. I tried this build and was prompted to approve the certificates and then I was able to login and get Toad Edge to load.