Toad World® Forums

Code Assist, setting for sql but not pl/sql?

I just upgraded to Toad 12.7 and I swear this was working yesterday but today it appears to be broken. I have reinstalled and wiped out the appdata file and still experience this behavior. I am fairly new to Toad, so it could be some setting that I have checked or unchecked but I can’t figure this out.

When I’m working in a package in the editor window and use a table alias and type a period after the alias, Toad will flash the busy icon (hour glass instead of mouse pointer) for a second, then does nothing. When I paste this same query into another editor window, Code Assist recognizes the alias and displays the list of fields. This works whether it is a new document or existing script.

I have tried opening the package from the schema browser (load into editor), from the ‘load object from database’ icon, and opening it as a saved file. Nothing :frowning:

In Code Assist I have PL/SQL Variables/Parameters, Functions, Packages (all), Procedures, Public Synonyms, Tables, and Views selected. I thought there was something like “Available Identifiers” but that is not in my list.

Any ideas?

Btw, I love that I can uncheck the ‘Space/Tab accepts selection’ boxes and that Code Assist still works when typing just before a semi-colon or closing parentheses.

Thanks!

Parrothead

Strange! Have you tried hitting CTRL + T? That’s the hotkey to force that code assist to pop up without waiting for the delay. Try that out and see if you experience the same result.

Nothing happens when I hit CTRL-T, just an hourglass for a second, then nothing.

Right now I’m creating a cursor in the ‘is’ (declare?) section of a procedure in a package. I wrote “select from apps.hr_all_people per where per.group_id = 123;”

Then I went back to the select part to start filling in the columns. As soon as I hit the space bar after select, I get the Code Assist pop up with EVERYTHING - why does the box pop up at this point? I haven’t entered anything, so how can it possibly have any idea what I want to do?

Without closing the box or hitting esc, I start typing the alias, ‘per’ and I get a list of objects that start with ‘per’ but when I hit the period, it automatically selects whatever is at the top of the list, instead of recognizing that I’ve entered an alias. So I back up and manage to get ‘per.’ entered without the pop-up, and nothing happens (just an hourglass for a second, and nothing). I hit backspace and enter the period again, and still nothing, just the hourglass for a second.

What the heck am I doing wrong? Do I have the wrong expectations for what a code assistant should be doing?

I apologize for not responding sooner; I haven’t yet figured out how to get notifications when someone replies to MY questions without getting every notification when anyone replies to any question.