Toad World® Forums

Toad for Oracle 12.10.0.30 Alias / Insight / Intellisense does not work. It flashes but does not pop up

I am thinking about moving back to an older version of Toad. I can hit Ctrl-T and bring up my table list but when I put an alias on the table and reference it for the list of columns in that table it flashes and nothing pops up.

I can take the table name and put the dot after it and pick my columns and then change the table name back but that is a pain to deal with.

I have my Insight set at 300 milliseconds.

I am also running Oracle 12c 64bit client as well.

Thank you

Gary Brown

PL/SQL Developer.

Are you trying to invoke it after an open parenthesis that does not have a matching close parenthesis?

For example… select lower(uo. from user_objects uo

It works with “select uo. from user_objects uo” and “select lower(uo.) from user_objects uo” but not in the unmatched example above. There are other examples of similar behavior where the statement is incomplete enough that Code Insight can’t detect the aliased table. Code Insight had a shift in statement parsing a few versions back where it changed from simple string searching to using a real parser. This allows for more advanced features, but does have a few limitations… this being one of them.

If this is not what you’re seeing please post sample SQL and indicate where you’re trying to use the alias and Code Insight.

Thanks,

Michael

I know what you are talking about with the Parentheses. I ran into that several versions ago. No this is just a regular use of an alias dot ...

For example

Select *
from employee emp
where emp.
;

Nothing pops up with the emp. .. It flashes like it is thinking about it but it does not pop up. It seems like it was working for a little while but then it quit. I thought about uninstalling and re-installing but I have too much to do to mess with it too much. I thought about just downloading an older version. I received a new laptop at work and installed the latest version of TOAD along with Oracle 12c. On my old laptop I had Oracle 11g and Toad 12.7.

I inserted some screenshots of a sample query and my code assist settings.

If the pick list doesn’t have anything to show it will still show a blank popup. This is to allow access to refresh button for clearing Code Insight cache in case cached results are no longer valid. Since it is flashing and not showing for you that suggests something outside of Code Insight may be cancelling it, but I can’t think of what that may be off the top of my head. Does your alias work anywhere else in your query like in the select list? Also, if you F4/Describe the alias does it say “Object emp not found” or does it resolve to some other object?

Michael

I think I figured something out... Not sure if this helps or hinders. This will take a bit to setup and explain. I will try to add some screen shots again too.

I went ahead and rebooted just now... just in case. But it did not help.

I tried to use the alias in other areas like within the Select part as below but it did not work there either. I did a F4 (describe) on mat in the Select and I got the dialog box you mentioned "Object mat not found". In this example.

Select mat.
from MON_ACTIVITY_TYPE mat
where mat.NAME in ( 'Appeal Sent Expedited_{B}[A]','Appeal Comment{B}_[A]')
;

So I went back in and tried some other options and it worked. I don't like having to type in the Schema name every time but it works if I do.

In our database we are given our own user_id to log in with. Then we either alter our schema to the schema we need or we have to put the schema name in front of the table name.

I put the main schema names we use in my "favorites" and then pick the one I want. This keeps me from running an Alter Schema command to change my schema. (Also at our work if we are inactive for a short time (researching, coding, etc..) they kill our sessions and we have to go back up to Sessions and Test All Connections (Reconnect) to hook back up. It is a pain but they will not change it. If I "alter" the session then I have to rerun the alter script again every time I reconnect but if I pick the schema from the Current schema drop-down then I don't have to do the Alter command when I reconnect. )

So If I put the schema name followed by the table name and then the alias the alias works as it is supposed to. But if I am in that schema and just use Ctrl-T and pick the table and then put on an alias it will not work.

Ding ding! Good stuff. Code Insight respects the current schema value when querying for objects, but when loading fields of a table or any other expression the current schema value was not being used. This is fixed in the next beta (12.11.0.63) and will be in the official 12.11 release.

Thanks,

Michael

Great to hear. I will keep an eye open for 12.11 to become available.