Code insight shows nothing

Occasionally, Code Insight does not display any hits, even after clicking the refresh button.

No SQL statements are logged during the refresh:

This may be because I had to reconnect the sessions this morning. I usually always leave TOAD open.
After restarting TOAD, Code Insight works as expected.

The error occurs from time to time, but so far I have not been able to recognise a fixed rule.

The connection is usually stable.

But what do you mean by "properly configured"?
I use an Oracle client for all connections, where the TNSNAMES.ORA contains all databases.


      (HOST=<ip4 addr>)

Sorry about that. Olive was a spammer. I showed her the :door: and gave her the :hiking_boot:.

I'll take a look at this today Dirk. You're probably right about reconnecting being related.

1 Like

when you start working in the morning, do you immediately reconnect all sessions before doing anything else, or only if you try something and then discover that your connection is lost?

I think the key to reproducing this has something to do with how connection is lost and what you do (or what Toad does) when it is lost. I say this based on bug reports/call stacks that I've seen in the past but haven't been able to solve. I see some things that look similar here.

I usually only reconnect a session if I realise that the connection has been dropped.

Sometimes I then immediately reconnect all the sesions.

I've been trying to reproduce this without any luck.

An easier solution than restarting Toad might be to go here and choose "Disconnect", then "Reconnect". Not sure if it will work but it's worth a shot. That "Disconnect" option does not close any windows. It just marks the connection as disconnected. In fact, one way to possibly prevent the problem might be to choose "Disconnect all" at the end of the day, then Reconnect all the next morning when you arrive.


I couldn't reproduce the problem this morning either.
The sessions were all disconnected, but after a reconnect the code insight worked again.

At the first connection I tried the "Disconnect" / "Reconnect" and it worked (of course) :wink:
At the second connection I tried just a "Reconnect" and it worked too.
At the third connection I tried a "Reconnect all lost connections" but this just reconnected the third since the fourth wasn't detected as lost.

I think I'll keep an eye on that and as soon as I get any new info I'll get back to you.

1 Like