Toad World® Forums

Computer looses network connection


#1

Hello,

Perhaps someone has had this problem before, please read in detail to understand the tests made and the problem in detail. It is a puzzling one perhaps and maibe only the best among you can suggest something.

I’m running SQL Navigator 5.5 on Windows XP SP3 with Oracle Client 9.2 connecting to Oracle databases 9 and 10g. We are updating the local workstation to a more recent one, on the old one with had SQL Navigator 5.5 working with the same OS platform and Oracle client without any problems. On the new workstation, whenever we leave Navigator open on the station, it ends up by loosing network connectivity, so much so that all network activity fails.

We took a long time to establish this connection with SQL Navigator, partially because the network failure mostly happens during the night.

Now for the facts:

  • It’s not network card configuration /power save options, all has been checked.
  • Workstation with SQL Navigator closed does not loose connection.
  • Workstation with only SQL Navigator on, looses connection, usually over night.
  • Not time relation could be establish (it does not seem to be after x hours)
  • It’s not faulty hardware, the workstation has been changed several times.
  • It’s not a problem with network hardware, location has been chanced.
  • On a request from Quest support we tested SQL Navigator 6.2 Trial, it had the same result.
  • When the workstation looses network, one or two reconnects in Navigator restore the network to normal state.
  • There are no fault or error entries in the workstation logs.
  • We cloned a machine where SQL Navigator Trial was working fine for weeks and installed SQL Navigator with our licence, it had the same problem.
  • We found a case similar to this one on the Quest support site, still it had references to Microsoft virtual PC wich we don’t have.

Common factor on this tests is the fact that we did it with our SLQ Navigator 5.5 registered.

Currently situation is,

  • One old workstation where SQL Navigator 5.5 registered, works without problems.
  • One new workstation where SQL Navigator 5.5 registered and 6.2 Trial have problems.
  • One new test workstation where SQL Navigator 5.5 trial had no problems, but where 5.5 registered now does not work.

Current test is,

  • Disconnect old workstation and keep it ofline.
  • Remove SQL Navigator 5.5 from the new workstation.
  • Reduce teste workstation software (services) to a minimum and leave SQL Navigator 5.5 registered, in order to see the result.

For those of you that like a good challange hope this one rattles your chain, understand that I do not request your assistance without weeks of tests, so please make valid suggestions.

Thank you to all that made it this far :wink:


#2

Hi Celia,

I got a support case recently about a similar issue as yours. In the end the customer informed us that there’s some kind of network lockup that causes the problem. Initially they thought that it only happens when Nav is running overnight but later confirmed that the lockup does appear when nav is not running. The case was closed because it’s identified as a network issue.

Cheers
Gwen


#3

Hello Gwen,

Thank you for your input, but in our case the tests have been going on for weeks now and so far the thing we did manage to really identify is that the new machines running Navigator 5.5 get disconnected from the network, if they are not running it noting happens and we can leave them on for days.

Further input on my part, just so you know first results from yesterdays test regarding the machine where we removed Navigator 5.5 and left only 6.2 Trial and left it on had no problems overnight, it’s still very soon to conclude anything so we will repeat the tests in the upcoming days. The other machine, the one that was cloned and was today running on minimal software and continued to have Nav 5.5 got disconnected.

Just so you also understand the level of disconnect that happens network wise, the machine reports no error, running diagnostics on the ethernet card report no malfunction and its not disconnected in anyway, to all accounts the ethernet card appears to be normal, however we cannot connect to anything via any protocol neither can we connect to the machine from the outside, a simple ping to the machine fails. forcing any other protocol like http, ftp, icmp, fails, trying to reestablish a connection on Nav 5.5 restores network operations to normal in a few seconds, where has disabling the card and enabling it or disconnecting the cable sometimes takes a long time to solve the problem.

Sorry for the long text, but it really is a lot of information and not a simple problem.

Thank you for your attention


#4

I too have the similar problem. The SQL Nav disconnects from database if it’s idle for 5-10 minutes while I am in the office connecting to the network through the docking station(ethernet cable). However, I can stay on as long as I want without any problem if I work from home connecting to the network through VPN. So far, i am only one having this problem. This problem happens to both SQL Nav 5.5 and 6.2(current), and preventing the code search to be completed because the timing.


#5

I have the same issue as Celia. I think it is significant because she said she had moved to a new workstation. I too am using SQL Navigator 5.5 on Windows XP SP3, but with Oracle Client 10g connecting to Oracle database 10g.

Here is a clue that might help. In the Event Viewer there was an error that occurred during the night:
Source: LSASRV
Category: SPNEGO
Computer: U0860465
The Security System detected an attempted downgrade attack for server cifs/V0860239. The failure code from authentication protocol Kerberos was "There are currently no logon servers available to service the logon request.

Here is what is significant about the above event:
The actual name of my computer is U0860465. In the server name in the message, “cifs/V0860239”, V0860239 is actually the name of my old PC, not a server at all. The new PC shouldn’t have any reason to connect to my old PC. (My old PC is still running, is on the same network, and is still on my desk, but I don’t think that matters here.)

I can’t find any SQL Nav config file or a setting in the SQL Nav menus that mentions V0860239.

As with Celia, the network connection issue persists until the moment Iclose SQL Navigator, so SQL Nav is clearly involved in the issue. My copy is alsolicensed. I don’t know if the license was somehow transferred from theold PC.

When I searched the C: drive for files that contain “v0860239”, I found that many shortcuts I’d copied from the old PC, including one for SQL Navigator, contained that text in the shortcut’s .lnk file, which is otherwise binary. I don’t see a way to access that info in the shortcut properties. I don’t know what that reference is, (why Microsoft in it’s infinite meddling wisdom saw the need for shortcuts to refer to the machine name), or how that reference might affect the applications.

I found that the .lnk file for the shortcut from the installation of SQL Nav on the new PC contains a reference to the new PC’s name. I’ll start using that shortcut, and see if it makes a difference.


#6

In the above post I forgot to actually say that, like Celia, I had moved to a new PC.


#7

Hello Bryan,

Thank you for all your input, I see our situation is truly almost the same, I too have my old PC still with Navigator instaled and still operational because it’s the only one working correctly. However, during all of our tests, a lot of them were with the old PC off, and the problem still persisted, so for now we’re rulling out communication between the machines and the possibility of a license conflict, also in the assistance we requested from Quest they mentioned nothing about this possibility.

We recently upgraded to the last version of 5.5 to work with Oracle 11g, however the local oracle client is still 9.2 because of some applications backwards compatibility. After this change we did some somewhat sucessful tests in wich at the end of the day we shutdown SQL Nav 5.5 opened it again, open only one connection to 11g and it seemed to hold for the weekend, no network loss, still it’s too early to conclude anything.

I will investigate the inputs you gave, look into the security event log and get back to you in a couple of days. Debuging and understanding this problem has been very dificult.

Thank you


#8

Hello Bryan,

some feed back for you, I looked in the event log and there where some events similar to yours however none of the refered the old PC, they did refer to another server and another machine, both of which have nothing to do with SQL Nav.

I looked around the net for such problem and found a number of sugestions that this might somehow be related to DNS and or domain login issues and some other Microsoft problem.

So I decided to make extensive changes to both machines, here’s what was done (please note that some of them where probably excessive but I have no more ideas on this issue so I’ll try anything logic :stuck_out_tongue: ):

  • Regional settings checking for correct zone and time.
  • Created a key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\LsaKerberos\Parameters
    and under it a REG_GZ value: MaxPacketSize=1 in order to force Kerberos to use TCP instead of UDP.
  • Set a registry key in order to eliminate caching of negative DNS replies.
  • Created entries for the domain servers in the lmhost file.
  • Made the Netlogon / Lanmanager service depend on the DNS service.
    -Removed the Old PC from the Domain.
    -Removed the new PC from the Domain.
    -Deleted any residual accounts from the domains.
    -Changed the name of the old PC.
    -Rejoined the domain with the new PC.
    -Rejoined the domain with the old PC.

This was done friday and we left the PC on with SQL Nav on, by Saturday it had lost network connectivity. No relevant events were recorded.

Best regards,


#9

Hi Celia

I got exactly the same problem and i opened a Support-Case. Did you hear anything about a solution yet?

Cheers
Beat


#10

Hi guys,

Just to let you know that we always keep an eye on this thread but unfortunately we haven’t been able to reproduce the issue. Because of that, we haven’t found any solution yet. We will keep you posted if more news come up.

Gwen


#11

Hello all,

Just too keep you up to date with our latest tests, something we never mentioned before is the hardware we’re using, because it never seemed relevant to the issue at hand.

For the new local workstation we’re using a HP Compaq dc7900 Small Form Factor.

We are now following a path of investigation guided towards this being and issue with SQL Navigator and the drivers and or network card, this machine has a built-in Intel Network Card (Intel® 82567LM-3 Gigabit Network), we tried diferent driver versions, all had the same problem.

So our most recent test included getting a diferent network card in this case a SiS 900 Fast Ethernet and disabling the build-in Intel Card.

The test so far:

  • 2 days without problems.

Considerations:

  • It’s still to early to tell if the solution will be stable enouth.
  • Current net card is 10/100 and Intel is 10/100/1000, however at this point we do not consider the speed to be the issue.
  • If tests go well for at least a week, we will try and get a 10/100/1000 card from a diferent builder to test.
  • I’ll give you some more feedback in about a week.

Those of you having problems please let me know the type of card you’re using.


#12

Celia,

Yes, I have the same network card:

Intel82567LM-3 Gigabit Network Connection

CPU is IntelCore2 Quad Q8200 @ 2.33 GHz

3.24 GB ofRAM

XP Pro SP3

I can reproduce the problem fairly dependably, so that I try to remember to close SQL Nav at the end of the day, because if not my network connection will be gone when I get back to work. Also, I can’t connect remotely when this happens.

Here is another hint towards getting at how SQL Nav is involved in blocking the connection. A couple of days ago when it happened, rather than just closing SQL Nav, I tried saving the file that was open in a SQL Nav editor window. After a pause, SQL Nav was able to save the file, which was stored on a networked drive. Of course, my DB sessions were lost, but I was able to reconnect without first closing/reopening SQL Nav. After having saved the file (or after having reconnected to the DB), my connection was restored for the entire PC.

I’ll be interested to see how your new card works out.

-Bryan


#13

Sorry for the gobbledegook in my last post. You can ignore everything between

“Yes, I have the same network card:”

and

“Intel82567LM-3 Gigabit Network Connection”


#14

Good morning

I have some new findings about the network loss:
For several times i had the same network loss over night while SQLNavigator was not running! The only thing i left running was a sqlplus task (sqlplus.exe SQL*Plus: Release 10.2.0.1.0). In the morning the network was lost. no application could access network. then i just closed sqlplus and network was accessible again. Outlook reported a reconnect, Network-Shares were back again.

Another time i left oracle Designer open-same thing- as i closed Oracle Designer network was back again.

So it could be an oracle client issue. If really oracle client is causing the problem and loses network, SQLNavigators problems rely on oracle as sqlNavigator uses oracle client installation for connecting the db

Oracle-Version we use:
used Oracle Client 10g from Oracle Warehouse Builder 10g: 10.2.0.2.8–>sqlplus 10.2.0.1.0
Oracle Designer 10g: 10.1.2.0.2 -->sqlplus 10.1.0.4.2

hope to give you some new hints with this.

Regards
Beat


#15

Hi Beat,

Thanks a lot for the update. Could you guys please try with sqlplus and other tools that uses Oracle and let us know if this issue could be replicated?

Thanks
Gwen


#16

Beat, just curious: When SQLPlus caused the issue, had SQL Nav been running when SQLPlus was opened? Also, had you migrated to a new PC from another PC where SQL Nav was working fine?

Last night I left SQLPlus running and connected. On a hunch, I started SQLPlus after closing SQL Nav, in case SQL Nav had something to do with Beat’s experience . I did not lose the network overnight.

Today, without having interrupted that SQLPlus session, I opened SQL Nav, with a couple of DB connections open. I edited a file there, didn’t save it, then didn’t use SQL Nav for a while because I was doing something else.

I was away from the PC for several minutes, and when I came back the network cx was lost. Windows Explorer couldn’t connect to networked folders, and MS Outlook couldn’t connect to the network. I closed SQL Nav. Usually (without SQLPlus) this would have restored the cx for both Windows Explorer and Outlook. It did restore the cx for Windows Explorer but not for Outlook. I waited more time, and connected to some different networked folders in Windows Explorer, thinking this might “wake up” the cx for Outlook. But Outlook did not restore it’s cx.

I exited from SQLPlus, and still Outlook did not restore it’s cx. I closed Outlook and reopened it, and it connected fine. So, I couldn’t tell whether SQLPlus was involved. Maybe after closing SQL Nav. I had to close Outlook and reopen it, regardless of whether SQLPlus was running. But in the past, (without SQLPlus running), when I closed SQL Nav, Outlook would have restored its own cx.

Today, SQLPlus is not running. if SQL Nav causes the issue, I’ll open SQLPlus and see if that restores the cx.

Tonight I’ll open SQLPlus after SQL Nav is open, and then close SQL Nav and leave SQL Plus open.


#17

Hi Bryan

In the past days i tried different versions of SQLPlus. Today i lost network cx with SQLPlus 9.0.1.4.0 left open. I always start SQLPlus when SQLNav is closed.

Yesterday i did this around midday, left other programs open, closed SQLNav and started SQLPlus. in Event Viewer there is a entry on 16:33 that outlook has lost network. So it happend not always overnight.
I had the same symptoms like you described. After closing SQLplus network drives where back but i also couldn’t reestablish the outlook connections, i had to restart outlook again.

About the migration question: i migrated in fall 2009. before this we never had such issues, SQLNav was working fine.
And still there are a few employees they haven’t changed to the new hardware (because of this issue). on their machines SQLNav is working fine.


#18

Beat, thanks for the info.

What network adapter do you have installed? Note in previous posts that Celia and I have the same one. Do you?

My test last night did not cause the issue. This involved starting SQLPlus while SQL Nav was running, and then exiting SQL Nav and leaving SQLPlus connected.

I’m looking into other reports of issues with that card. But I’m no network engineer.


#19

Hi Bryan

Yes, indeed i do have the same network adapter:
Intel 82567ML-3Gigabit Network Connection

My current test i startet yesterday, i had no connection loss this night. So it depends always… But if you could test it over the weekend too, that’ll be great!

Regards
Beat


#20

So it seems pretty clear there is some kind of bug with Intel 82567ML-3 Gigabit Network Connection, which SQL Navigator is running into. SQL Nav apparently doesn’t have this issue with any other adapter in use. That’s good news for Quest!

I was running driver version 10.3.39.0. There is a driver upgrade available for Intel 82567ML-3 Gigabit Network Connection. This upgrade installs driver version 11.2.19.250. I didn’t find it when I searched the Intel site (see info below). I installed it yesterday morning, and I left SQL Nav running at the end of the day to test it. Unfortunately, my PC support department pushed out an emergency Microsoft Security Patch last night, and it restarted the PC. Anyway, I had SQL Nav running all day yesterday, and didn’t get the issue.

I won’t try the test again until maybe Monday night, in case I need to connect remotely over the weekend. But I’ll be using SQL Nav all day today. Here is the info in case any of you want to try the upgrade.

Go to this site, and download the file.
http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?swItem=ir-77074-1&taskId=135&swLang=13&swEnvOID=1093&lang=en&cc=us&idx=0&mode=4&

The Website doesn’t have complete instructions for the install. So first follow those instructions, and accept the default location for the files. Then, go to Control Panel | System | Device Manager | Driver tab.
Select Update Driver…
“Can Windows connect to Windows Update to …”
Select “No, not this time”
“What do you want the wizard to do?”
Select “Install from a list or specific location”
On next screen, leave “Search for the best driver…” selected. Select “Include this location in the search.”
Click the Browse button, and select the folder, C:\swsetup\SP45881
Click Next.