Toad World® Forums

SQL Navigator 6.7.0.2372 - Frequent Random hanging...

Firstly, I’ve searched the forum for the said problem in title and have tried most of them but to no avail…

Basically, SQL Nav just keeps hanging… and I have to force close it by Windows task manager…

It is very random, and very (frustratingly) frequent… I can’t even add a line to a SQL script on restart without it hanging (on intellisence look-up)

And information would be gratefully welcome…

Thanks

Chris…

Environment…

Windows 7 Ultimate x64
Oracle Client 10.1.0
DB Version 10.1.0.5.0

Hi Chris,

I would like to suggest that you should try with build 2378. I have uploaded the sqlnavigator.exe to the following location:

toadsoft.com/…/sqlnavigator.zip

Please rename the current build 2372 in the installation folder before you copy the build 2378.

We have done some work in that area with the patch but not sure if it would address your issue.

If you still get same issue with the patch, Please check with the current Beta v7.0 build - www.toadworld.com/…/default.aspx

Please let us know how it goes.

Thanks and regards,

Bruce

Is it just a EXE replacement Bruce?

Well, I dumped in the new EXE and I have to say that it is now stable… I have not had a crash since… Many thanks…

Dang it… spoke too soon… just crashed again on me :frowning:

** HHHEEELLLPPPP****

It’s driving me crazy… having to restart after 1 or 2 queries!

Hi Chris,

Could you please try to backup %appdata%\quest software\sql navigator 6.7 and then delete this folder? restart sqlnav and whether you still have problem.

thanks.

See how big the History is, Navigator is troubling if you have over 5000 entries, try the cleanup and leave the last 15 days or less.

Untitled.png

Tried both of the “Clear History” (completely empty) and reset of AppData folder, still hanging… thanks though.

Hi Chris,

Thanks for letting us know. Sorry to hear that you still get the issue.

Much appreciated if you could please try the v7.0 Beta build from toadsoft.com/…/sqlnav_7.0.0.2962-KX_beta.zip

(114mb) and see if the hang issue would be resolved.

Thanks and regards,

Bruce

Cheers Bruce… Will give it a shot…

Bruce… Have downloaded and installed but when I run, it wont connect to any database as gives “ORA-12154: TNS:could not resolve the connect identifier specified”

Works fine on my 6.7 install and settings appear to all be the same

Hi Chris,

Thanks for trying the new beta and sorry to hear you have problem with it.

How many Oracle Clients/Homes do you have in this environment? Did you try to select/switch Oracle client in sqlnav Logon window? And last thing, could you use 6.7 to log in to one of your DBs and then create a support bundle from Help -> Create Support Bundle Files? Please email me the support bundle file to Vincent.Liu@quest.com.

Thanks,

Vincent

Email sent Vincent… :wink:

Thanks for the files Chris.

We could not find out any possible cause of TNS error from the support bundle. Can you please confirm that you installed both 6.7 and 7.0 in this machine? In 7.0, are you using TNS or LDAP tab in connect in sqlnav Logon window? If you are using TNS connection and you should have the details(host, port, service_name etc…) of the database connection, could you use the details to make a Direct connection in sqlnav logon window?

I hope direct connection will work for you temporarily before we figure out the initial issues you have. Please let us know how it goes.

Thanks,

Vincent

Hi Chris,

Thanks for sending Vincent the info. We are still looking into the connection issues with v7.0 you had.

With the hang issue in v6.7, could you please rename the registry folder SQL Navigator 6.7.0 under HKEY_CURRENT_USER\Software\Quest Software, ie. we will start with a fresh/default layout. I saw that you have auto hide ON for dockable windows layout.

I suspect there might be some corruption with dexexpress layout settings in your 6.7 registry.

If you still get the hang with a clean registry, please try to turn OFF the saving sql to history option in the preference window as attached image.

Please let us know how it does. Many thanks for your help working with us.

Thanks and regards,

Bruce