Toad World® Forums

Copying or duplicate Entities?

I see no way of duplicating or copying/pasting a table/entity within the same workspace - is this not possible? There are many times I’m extending a database based on what is already there and the tables are nearly identical, I see now way of doing this simple thing?

I did search for this answer and found nothing relevant.

Same for procedures, can’t see any way of performing this either. Both allow me to reduce the time of creating indexes (which often are the same), setting permissions, and utilizing identical code quickly.

you will need to edit the object you want to duplicate (right-click --> edit). This will allow you to create a sql script that you can edit with your changes and then execute it.

That’s if I only want it on the server, I’m looking to create new objects in Toad itself while retaining all the items associated with the object; permissions, indexes, comments, arguments, etc. I hope with the rolling back of this product to Quest away from Dell means good things for the product in the future. Simple things like undo after mistyping on a stored procedure don’t function.

Not sure where my previous reply went to on this, however your solution only addresses getting the object into the database, I’m looking to have the object duplicated within Toad. I want it duplicated with the associated items related to it; indexes, permissions, comments, etc.

Hi,

there are plenty of ways how to duplicating or copying objects in TDM. Objects on workspace (entities, views, …) can be simply copied and inserted by CTRL+C / CTRL+V (or by the commands from the menu Edit). You can also use drag & drop techniques both at the workspace or in the model explorer (click e.g. the procedure, hold the left mouse key down, press and hold down CTRL key and drag the procedure to the Procedures folder). It’s also possible to use drag & drop techniques to copy attributes, triggers, check constraint, … in the e.g. Entity properties form. In case you have any other questions, don’t hesitate to ask us.

Regards,

David

Well one of your options did work, the ctrl-drag did create a duplicate - thanks much. The ctrl-c/ctrl-v did not do anything nor did using the copy/paste commands from the edit menu. However I’m good with the drag/drop method at this point, thanks.

The CTRL+C/CTRL+V should works normally. I tried it in TDM 6.3 & 6.2 without any problems. Just click the entity (e.g. Film) on the workspace to select it, press CTRL+C & CTRL+V to copy and paste it and a new copy of this object should appears. Could you tell us what version of TDM do you use and what is your OS? Is it a regular PC or a virtual machine?

You can also create a copy of some objects by ctrl+drag from the model explorer to the workspace and vice versa.

Yeah, that’s exactly what I was doing and had no success. I’m using version 6.3.2.22, 64 bit. I’m running Windows 7 Pro, 64 bit. I also have 6.2.4.30 installed (64 bit) and the problem exists there as well. I recently switched from the 32 bit to 64 bit installs, and hadn’t tried copying/pasting in those versions.

That’s really weird behaviour. I tried both version on the same OS without any problems. It looks like copy & paste commands are executed over a different window… Please could you send us a screenshot of whole TDM? You can upload it here or send it to me via email.

Regards,

David